Back to the main site

It appears that Lutris is no longer viable

I have tried for the last 2 hours to get ubisoft connect working so I can install assassins creed valhalla but because ubuntu 21.10 does not have 32 bit libraries any longer and lutris does not use a proper 32 bit ge wine implementation ubisoft connect will not work. Any hints as to how I can get it working? or is lutris just no longer able to keep up with changes? Any help is appreciated.

2 Likes

Interesting, and I say this because Since The Division has been playable on Linux I have loaded Ubisoft games and gotten them to work. Also the 32bit libs have not been in any ubuntu distro since 18.04. Also a 32bit wine implementation is not required to run a 32bit game. A 64bit wine version can run it.

How do you think they are doing it on Windows that is 64bit only? The 32b it libraries are Linux libraries that have been worked around since the first talk about doing away with them. If you give more info on the issue like details we may be able to help you.

Read this thread they have a way to make it work. Can't login to Ubisoft connect - #5 by Freejack

1 Like

I upgraded to 22.04, installed Lutris again just to try and installed ubisoft connect. It would not launch. did some searching and found out I had to modify a config.py file to make it work. I did that and now ubisoft connect launches, asks for my credentials and low and behold still won’t connect to the internet. Everyone says people need lib32-gnutls which is not a library file available for Ubuntu 22.04 so I am back where I have always been with lutris, it simply does not work correctly any longer.

Ubuntu doesn’t name it “lib32-gnutls” it would be more like gnutls:i386

Note that I have not used a *buntu distribution in several years, so forgive me if this command doesn’t work out of the box, but it would be something like:

“sudo apt-get install gnutls-bin:i386”

(which would install split out libgnutls:i386 and friends as dependencies.)

This shit is still there in Jammy, I looked it up:
https://packages.ubuntu.com/jammy/i386/gnutls-bin/download

I got thinking about this, and I don’t think you want/need the 32 bit gnutls utilities (gnutls-bin:i386) just the libraries.

Install libgnutls30:i386

apt-get install libgnutls30:i386

That will also install its dependencies.

Already installed. Makes no difference. Ubisoft Connect still can’t connect just says Lost Connection so I have no idea if the game will even run because I can’t get past that.

If you want to see what the debug is saying I pasted it here Ubuntu Pastebin however, I watched the terminal window and there was no output when ubisoft was trying to connect or after it failed. Only once I closed the dialog and stopped the app was there more output.

Streamer-WARNING **: 07:55:52.074: Failed to load plugin ‘/home/bartb1959/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/libgstdtls.so’: libcrypto.so.1.1: wrong ELF class: ELFCLASS64

I’m not sure if that’s your showstopper error or not, but it looks like you don’t have (32 bit) openssl 1.1. It looks like Ubuntu 22.0.4 does not provide that, so you’d have to get it by other means. In their arrogance, they think they can force everyone to use OpenSSL 3.0, though it’s not compatible with a lot of software. A distro needs to provide BOTH if they are shipping OpenSSL 3.0. Ubuntu thinks everyone should run things in containers now.

That could very well be the reason for your lack of connectivity.

1 Like

I found and installed openssl1.1.1 and libssl1.1.1 and rebooted. This is a no go as well. Here is the pastebin Ubuntu Pastebin. I notice that line 63 shows WSALookupService fails. not sure if that is the issue or not but it doesn’t list a missing library just that the service failed.

I also tried it using wine staging 7.8 Ubuntu Pastebin

That could be your show stopper as it’s coming from an embedded chrome browser (which is the UI in your game client). I can’t actually see the error in your pastebin, but that’s what I’ve seen that error on (referencing a source code file from chromium where the fault occurred) but usually it is followed by a crash-like event with “unhandled exception” (which is all it knows to spit out).

Oh, I see it in your second pastebin:
ERROR:network_change_notifier_win.cc(228)] WSALookupServiceBegin failed with: 0

Yes, that’s exactly the error I’m thinking of. I see it a few times, so it probably is failing (I mean failing to set up a connection). It’s a winsock 2 function for checking for a network connection.

I’m going to go out on a limb here and ask if you somehow have ipv6 disabled. A lot of these asshole game clients will fail when they hit that protocol error rather than continue on with ipv4 as normal. It’s probably not this, I just want to mention it.

my vpn connections disable ipv6 but my wired connection has it set to automatic. I will also say I have games in steam that require ubisoft connect and they do not fail to connect so this is definitely something in how Lutris handles this part.

Steam sets up runtime environments in bwrap containers, so that’s a clue if the ubisoft client works there. It will be related to libraries.

What happens if you “disable Lutris runtime environment” for that wine prefix? It could cause it to work using only system libraries. Bundling libraries can break because they still have to interface with dependencies on the system, and the APIs may have changed. It may not change anything (default is to “prefer system libraries”) or may cause the client to no longer launch at all, never mind connect, but it’s just a checkbox.

1 Like

I tried disabling it and leaving prefer system libraries enabled. tried with disable on and prefer system libraries off as well but it didn’t make a difference. The connect app starts, asks for login and fails to connect no matter which setting or combinations I use. I just tried running Ghost Recon on Steam which I hadn’t tried to run since I did a clean install of Ubuntu 22.04 a few weeks ago. I get the same issue with that game that worked fine under 21.04 so it appears no games that use ubisoft connect to start will run on steam or lutris on Ubuntu 22.04. That’s unfortunate. guess I just won’t be able to purchase any ubisoft games any longer.

Got a new issue. So the ghost recon not starting and getting the error about servers not being available turns out was actually ubisoft servers not being available. go figure. Ghost Recon now starts without issue. But, in the meantime I had uninstalled lutris and deleted all the lutris folders so I figured I would reinstall and try ubisoft connect again. Now it won’t install and I get an error, OSError(5, ‘Input/output error’), during wine config update. Here is the pastebin for the lutris.log file. Ubuntu Pastebin

false alarm. turns out one of my USB drives was not mounted correctly and I had to fix that issue first. I will update if ubisoft connect successfully connects.

Houston we have liftoff!! now if only the game runs. we’ll see.

1 Like

Maybe you can help with this. the game runs but flashes black for a second or two constantly. I read somewhere that turning off Depth Of Field is a fix but not for me. Any ideas on this issue using Lutris?

Here is a video to show what is happening. - YouTube

I’ve had that happen with some games, and the answer was to switch to a wine runner (and/or dxvk) that they liked better. For example My EA Origin wine prefix is fine with current Lutris 7.2, but older Frosbite engine games were “flashing black for a second or two constantly” so I switched it back to lutris-6.21-6 and dxvk 1.9.2L-3e64e1b which solved the problem, and it’s fine because all my other Origin games are happy with that configuration too.

I think I figured it out. The dxvk folder has a version.json file that will always download the latest version and put it in that folder so I had to create a folder to cut and paste those into so I could add v1.9.2 to that folder. I also used 6.21-6 with the latest dxvk and with 1.9.2 and neither of those worked. I tried a bunch of different ones with no success. all the way down to 6.16 before the game wouldn’t launch. That is not apparently the issue but thanks for the suggestion.