Back to the main site

How to setup DXVK on Lutris


#1

Automatically update DXVK with new binary releases
#2

Thank you !


#3

Tried it with Nier:Automata which is supposed to work well with DXVK, but the game crashes shortly after launching.

This there anything in addition that needs to be configured? I am on Solus Linux using wine3.4-staging for this. Without DXVK Nier:Automata actually runs on this systen, but it is a bit slow with normal DX11->OpenGL conversion.

Edit: strange… now it seems to also do the same error without DXVK. It did some strange file verifying and updating while testing DXVK… did that somehow brake my install?

Edit:2 ok seems to work now. I guess disabling the steam overlay made it work?


#4

Thank you! Wolfenstein Colossus and Doom play perfect. Max settings, plays smoother than Windows. The days of dual booting are almost over. I was experiencing some slight audio/choppiness and found this on WiineHQ.

“If you are experiencing audio choppiness/stutter, try installing 64bit version of XAudio2_7 via winetricks:”

WINEARCH=win64 winetricks xact


#5

I try to many times to install xact in playonlinux or wine without success.


#6

This is the command I used" WINEARCH=win64 WINEPREFIX=/home/spaceballs/Games/DXVK winetricks xact "

Obviously, you need to change the path to your wineprefix.


#7

what happened with this video?


#8

what happened with this video? ???


#9

Forgot to add the new one.


#10

tks for reply!!!

after install steam I change Steam.exe, for the exe inside the prefix then doesn’t open anymore, crash everytime, did you have any ideia what happen???


#11

Try turning off the runtime? Also you don’t need to use Steam like I showed you can just use the Wine Steam runner.


#12

Unfortunatly, not working, but I found a way, just add a “dwrite” dll in wine Library and desactivated, some games here plays without sound, like GTA V, then I need to check disable runtime and reduce pulse audio latence, then everything works, now the problem is Steam Store, not work, with playonlinux and wine 2.21 staging I was setting compatibility to WinXP and put the argument “no-cef-sandbox” to work Steam Store but now nothng happens, and sometimes Steam just close, very weird…


#13

think its meant to be -no-cef-sandbox (is not --)

UPDATE: Fixed KCD, missed those damn DLLs from KCD bin directory. D’oh


#14

I just tested witcher3, and it runs at 4k above 60fps LMAO (mostly low settings). Bit of stuttering, probably not helped by having it on spinning rust. Fallout4 and WarThunder crash however. (I suspect Warthunder has many DX9/10 parts)


#15

I try KCD, with dxvk game crash, but with wine 3.5 staging with d3d normal runs with a low fps, about -no-cef-sandbox don’t work, I can run steam just if I put “dwrite” but in a less than a minute Steam close, I really don’t know what happen.


#16

I figured out what I did wrong, I missed the part where you copy the two dll’s from one KCD dir to another. I was following a general DXVK guide which was not for KCD so I got misdirected a little bit.

It works now, 35fps on medium settings at 4k on my 1080ti. I hope to improve that FPS in the future, I think under windows I get 50fps in same area (starter) so its close.

I would love to get War Thunder DX11 working and also Fallout4, both which crash on launch for some reason. I did get SkyrimSE working but it has this nasty texture flickering on almost everything, thought framerate seems ok.

@tuxtergames steam can be a bit crashy, be sure to have it on windows7 config and not windows10. Or older. ATM I’m running very vanilla dxvk setup.


#17

Hi, I tried a lot but not working Steam Store, even folow your steps, by the way, I’m trying Steam through Playonlinux with vulkan and works very nice without crash, maybe someone can report to Lutris devs, and Steam Store not working in Playonlinux, if I use -no-cef-sandbox and compatibility WINXP works well, see the print screen, maybe someone know some voodoo to do into the registry, cause somegames won’t work with winXp compatibility.
OBS: for Steam open nice and Lutris I need to put “dwrite” Dll and wine library and desactivate it to run.


#18

The Steam store works for me but tbh I’d suggest you just use the Wine Steam runner. My video was just a demo for installing DXVK onto a prefix. To be honest I shouldn’t have shown how to install Steam on that video given how Lutris handles the games with it. However, I could make a video on how to install a Wine Steam game with DXVK manually if you want. It’s almost the exact same process as I showed.

Plus, once Strider irons out some kinks, that’s how we’ll be shipping DXVK installers for Steam games. In fact I already have some written up myself I’m just waiting on his fixes.


#19

Try Windows 2003 or is it 2013? I think I had success with steam working on that on also back in the day when I had issues like this.

Steam does seem unstable with Win7+ in Lutris at times, and my KCD game crashes my computer at a specific spot so perhaps I should test it out with PlayOnLinux sometime also.


#20

Very nice record a new video how to, just to check what happen here and what I doing wrong…
By the way did you try another DRM, like Origin or Uplay with DXVK, not working here.