Back to the main site

How do I use a different browser for flash games?


#1

Hello all,

So I backed a game on kickstarter, and the resulting download is a flash game. So I’m trying to play it, but Firefox is not letting me run flash, because of the end of life issue. I would like to set Lutris to launch the game through chromium. But I can’t figure out how to manually configure that in the settings. Does anyone know how to set a different browser to open other then your system default?


#2

I would think if the game won’t run by changing your default browser to chromium then the game needs firefox to run. I don’t know for sure. The only thing I could suggest is to try and install the game without using Lutris and setting your default browser to Chrome or Chromium. I need to leave for an appointment now, but if you are interested in trying getting this game installed manually just let me know.


#3

I actually just figured it out! Still throwing an error saying flash isn’t installed, but that’s not really the purpose of this forum.

What I did what, I used the whereis command to find where chromium-browser is installed. Then I went into the game settings>runner options>[directory where chromium-browser is installed] and double clicked on the browser launcher. Bam! Opens in chromium.

I was having trouble finding where chromium-browser was installed, and thought there was a drop down list or something, that I wasn’t seeing.


#4

Come to think of it, shouldn’t Lutris allow for using an external Flash player (like the standalone Adobe one)? I would say that those are generally more convenient for flash games.


#5

does it? That would be better for me, the browser doesn’t allow for save games sadly. So I’ll either have to finish the game in one sitting, or leave it running between play sessions. Any idea how to run that flash player through lutris?


#6

I don’t think it does. I think it should.


#7

Ah, I understand. I posted about this on the mint forums as well, someone recommended flashplayer_30_sa.exe running under wine. But I can’t seem to find a download for it myself. Anyone know where to find that?


#8

If you look up “adobe flash standalone”, the first link will probably be this one, which contains the latest Adobe Flash player (v32.0.0.171 as of today) for all PC platforms. Just go to the section of your choice and pick “Download the Flash Player projector” (that’s what they call their standalone releases).

Speaking of which, you could probably set up your flash game in Lutris as a native one by passing Flash player as the binary and game file as parameter (might want to set up a workdir too for multifile games)


#9

I actually did try downloading the projector for Linux already. And opening the game with it too. I got a blank screen for my trouble. Just a white screen, with no video or audio.

Edit:
Quick question, is it possible to add our own custom runner to Lutris? If I was to copy over the projector to the runner folder, could I set it as a runner for games?


#10

Well that’s weird… It works for me just fine, I already set up the MIME for it to open flash files & stuff :man_shrugging:

As for your question, I’m not sure if creating a personal runner would be possible (I think they use a remote list?…), but as I mentioned before it won’t be a problem to set it up as a ‘native’ game. Here’s a working example (selected runner is “Linux (Runs native games)”):


#11

:man_facepalming: got it. The moment you showed the swf file. Flash games normally aren’t my thing, so I didn’t bother with that file. I was trying to run everything through the html file. Which gave me the blank screen. Loaded the swf file, and it went right to the main menu. I still need to test it, but its looking good so far.

And I see what your doing, I think. Your just opening the flash player itself. But how does the arguments portion work? Do I need to specify the swf file manually? Or can I just tell my system to always open swf files with flash player?

Edit: Ok, so it turns out you cannot just tell your system to open SWF files, then try to run it in lutris. If its not an executable, it throws an error saying as much. So instead, I tried setting up my paths like yours. And flash does load, with the swf file in the address bar. But then…nothing. It just sits there.

Once flash player is opened, I can manually browse to and open the file no problem. But it doesn’t do that automatically. I even tried pre-loading the game directory, and adding the game directory to the bottom row. nothing.


#12

If you’re talking about Lutris, then the “executable” field is supposed to be where the executable file goes – in this case Flash player, and the “arguments” is where the filename goes (CLI usage for Adobe Flash player is flashplayer [filename.swf]).

If you’re talking about system-wide install (running SWF files from file manager or using exo-open/mimeopen), you need to set it up in your system. I use XFCE, but I imagine most of it would be similar for any other DE.
So, the first thing is obviously to put the binary somewhere in system folders (/usr/local/bin/ is the one designated for that purpose). Then, you want to declare it as an application; I did it by creating a file /usr/local/share/applications/flash-player.desktop:

[Desktop Entry]
Name=Adobe Flash Player
Comment=Adobe Flash Player
Exec=flashplayer
Icon=flashplayer
Terminal=false
Type=Application
StartupNotify=true
Categories=AudioVideo;Audio;Video;Player;TV;

I also looked up a round icon for it and placed it in /usr/local/share/pixmaps/flashplayer.png to tell it apart from flash-player-properties in the menus n’stuff. The app appeared in the Multimedia section of application menu.

After that, I’ve connected the file type to the app using xfce4-mime-settings (obviously other DEs use different tools… or you may try doing it in settings of an SWF file); the MIME type I had to find was application/vnd.adobe.flash.movie (no idea why it’s listed under that name).

If you don’t like the icon used for SWF files (my system defaulted to regular video file icon) you can set it up too; just add your own image (I named it /usr/local/share/pixmaps/flash-file.png), and create a file /usr/local/share/mime/packages/flash.xml with this content:

<?xml version="1.0" encoding="UTF-8"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
  <mime-type type="application/vnd.adobe.flash.movie">
    <comment>Shockwave Flash file</comment>
    <alias type="application/x-shockwave-flash"/>
    <alias type="application/futuresplash"/>
    <generic-icon name="flash-file"/>
    <icon name="flash-file"/>
    <magic priority="50">
      <match value="FWS" type="string" offset="0"/>
      <match value="CWS" type="string" offset="0"/>
    </magic>
    <glob pattern="*.swf"/>
    <glob pattern="*.spl"/>
  </mime-type>
</mime-info>

Then run update-mime-database /usr/local/share/mime/ to register it.


#13

Try to run it from terminal. I my case it would go like this:

$ cd ~/Games/Flash
$ /usr/local/bin/flashplayer N.swf

(Or simply flashplayer N.swf as /usr/local/bin is in $PATH).

…Incidentally, does your game filename include whitespaces? Because whitespaces are used for separating command line arguments, so you have to mind them.


#14

The file does have an underscore, but no actual spaces. The game folder did however. When I ran the command from the CLI, after navigating to the swf file, flash player did run the game.

tbh, i’m not sure whats going wrong. My executable is the flash player’s location (for simplicity’s sake, I did stick it in the same folder you have), my argument is the games swf file, and my working directory is the games swf file location.

Edit: I was able to get the game to run, I just had to change the settings to run it in a terminal. Is there anyway to get it to run w/out the terminal?


#15

There’s gotta be, considering it works for me :smiley:
However, in your case, I can’t say how to fix it as I can’t tell what the cause of the problem is.
Maybe you can provide more specific information? Like a screenshot of your config, as well as exact filename and location?

Regarding whitespaces in arguments: leaving them be will cause the argument be treated as several; you have to either put them in single/double quotes (but ~/ part should stay outside of the quotes or it won’t be expanded: ~/"Flash games/Some game.swf"), or escape them (placing a backslash before every whitespace character: ~/Flash\ games/Some\ game.swf). It’s a Bash thing so rule applies to command line calls as well (or rather, that’s what it’s about).


#16

the game title is…kinda embarrassing. Its an adult game, I’ll say that much at least.

The file is located in: ~/Games/[GameTitle]/game/data/chap1_v01.swf (game title has no spaces in the folder name). Is that underscore a white space? I have the executable set to: /usr/local/bin/flashplayer. Do you want to know the system options I have enabled? Though, tbh, I haven’t actually changed anything from the defaults, except running the launch command in the terminal.

How do I take a screenshot in Linux? I can just fire up the snipping tool in windows, but Linux doesn’t seem to have that option.


#17

You don’t really have to use the actual game name in the path while you’re experimenting, yanno :smiley:
Though not knowing the name would prevent me from trying to test it myself, I suppose.

The only thing I can tell from the path you provided is that it’s likely not the intended file to be opened (I may be wrong, of course, but this looks like a multifile SWF game, and those tend to have a ‘master’ SWF which takes content from other files).

Underscore is not a whitespace; whitespace characters are the ones without ‘visible’ representation in most fonts (space, newline, tab, etc.), and the only one trivial to type in shell as a text character is space. So unless your $HOME (~) has whitespaces in it, this path doesn’t contain those. …Speaking of which, some non-alphanumeric characters also need to be quoted/escaped in CLI as they have special meaning (like semicolon which starts a new command).

There’s multiple tools in Linux for that purpose, both DE-specific and general (as is with most X utilities). In XFCE I normally use xfce4-screenshooter; a quick check in package manager says there’s also spectacle (KDE), gnome-screenshot (Gnome), screengrab (LXQt), maim, shutter and shutterbug (in my distributive). So there should be plenty of options available – just pick whichever works for you.


#18

Yea, this isn’t a publicly available game. So, unless you back the patreon, you shouldn’t be able to download the game.

Yea, this is meant to be a browser game. So its probably not meant to be run through flash alone. It does run though, it just doesn’t save the game progress past a system reboot.

So a white space is like a space in the name then? Like “Game Title” instead of “GameTitle”.

And, as it turns out, I have gnome screenshot installed! Ok, what would you like images of?


#19

That’s not what I’m talking about. When there’s multiple SWF files, usually one of them is the ‘main’ one, managing gameplay, saves and whatnot, and it’s the one you run to play; the rest of the files are ‘chunks’ meant to store content managed by the ‘main’ one (essentially data files). The only exception to that would be ‘episodic’ games split into completely unconnected parts of the storyline.
Usually when there’s a ‘main’ SWF file, the HTML index file would contain a static link to it and little else.

Basically yes, although it is technically possible to have other whitespace characters in the file name (I accidentally made a file name which included a newline… that file wasn’t easy to use in the shell :smiley:)

Well… Anything that could help figure out what might be wrong?
Game options (to see if you missed anything), file structure of the game folder might help too…
Maybe a screenshot of the shell to verify you’re running the game from it same way as you set up game options (cd to the workdir, then call flashplayer in the same path with the same exact argument string) when you say it works differently :smiley:


#20

There’s actually only the 1 SWF file, an HTML file, and a jpg file in the folder. There’s nothing else in the folder.

Oh, gotcha. Well…I don’t actually, I’m still learning Linux, but I’m going to smile and nod.

Ok, so my settings:
[spoiler]

[/spoiler]
my settings:
[spoiler] [/spoiler]

I’ll get the cli in a bit