Back to the main site

Help with Star Wars Battlefront 2015

Thanks. Now the login success, and the install too.
But the game crache by startup with a page fault.
The Wine build: tkg-protonified-3.21-1-g341b86d is the correct one to use?

Try the latest wine version. 3.21 is pretty old now and the installer hasn’t been updated even though Origin and SW Battlefront work well with many newer versions of Wine.

I just started it up successfully using the lutris-4.21 Wine version.

Also tried it with lutris-4.21 - not starting, cause of “Unhandled exception: page fault on write access to 0x7b423ef0 in 64-bit code (0x000000007b423ef0)”. I guess a library is missing or whatever.
I’m giving it up, that’s enough time i spend on it. Downloaded the >50GB 3 times :frowning:

Hmm that’s unfortunate. Maybe your file permissions aren’t set correctly?

You shouldn’t usually need to redownload the game files, if you just move them from your old prefix to your new one, and put them in the origin games folder specified in the Origin settings, then Origin will just check the files for corruption, and re-download only the missing or corrupted files.

One thing that comes to mind is that you might be trying to use an NTFS partition to install your prefix on, which would fail, because the file permissions can’t be set by Linux on NTFS.
You’d need an ETX4 linux filesystem, or some other Linux file permissions compatible filesystem for your games prefixes.

If you want to reuse your existing SWBF files, just make sure you take ownership of their files and set read and write access permissions on them once they’re on an EXT4 or other fully Linux compatible filesystem.

All ext4 and the files permissions are all r/w for my user. So that was not the problem.

Hmm. Scratching my head on this one.
Are you using a 64 bit prefix?

If you want to test it further, you can try using the same wine version in Lurtis with different games, and see if you have errors with those too.

In the console output it says 64bit prefix. The only other game I tried was skyrim. It stars. So I tried to start Battlefront 2015 with ‘Proton 4.2’. The first time it says that there is something with .Net missing. Maybe it is also the problem with the other runner ‘lutris-4.12.1_x86_64’ ?
Please keep in mind, that I’m not familiar with .Net - I just know it something from microsoft

That’s interesting.

There’s a wine component called “Wine-Mono”, which simulates the .Net framework in wine. Wine-Mono is usually supposed to install itself into your prefix when you set it up, but I’ve had lots of instances in the past usually with Playonlinux, where it didn’t install properly.

If you click on your game launcher in Lutris, and then click the winetricks button on the right, and then you can basically follow this video to install or reinstall wine-mono:

Edit:
Actually I vaguely recall that wine-mono may have been replaced by something else and is no longer used. So I could be wrong about the need to install wine-mono. It might be out of date information.

Here’s a link that says wine-mono is still in development though, so not sure:
https://www.phoronix.com/scan.php?page=news_item&px=Wine-4.6-Bringing-Shared-Mono

With wine-mono installed the game is still not starting.

Hmm. Figures, it was a bit of a long shot.
Winetricks will let you install dotnet versions, but I kind of doubt that’ll work.

Actually wait. I just remembered that I had to turn off the Origin overlay in the Origin settings in order to run SW Battlefront.
That could well be the problem.

Oh, yes. The origin ‘overlay’ was the problem :smiley:
I found the button to deactivate it in origin under the game properties of Star Wars Battlefront 2015.
Thanks.

1 Like

Bgah! Kicking myself, it’s the most obvious thing I should have mentioned at the beginning :stuck_out_tongue:

Good that it works!

1 Like

When I try to launch Battlefront I get the error “Detected NVIDIA GeForce driver version 337.88. The required driver version is 358.91 or later.”
I have a GTX 970 with the Nvidia 430.40 driver.
I double checked that the nvapi,nvapi64 is disabled in the runner options.
My dxvk.conf file:
dxgi.customVendorId = 10de
dxgi.nvapiHack = False

I also tried renaming the nvapi64.dll file in windows/system32/, but it didn’t help.

During the installation of Origin (Battlefront 2015 script from Lutris) I choose the Nvidia graphics card option. I also tried the AMD option (didn’t work, too).

I disabled DXVK in the system options (didn’t help).

My system:
Kubuntu 18.04.3 (64 Bit)
Kernel: 5.0.0-23-generic

Hmm. Yeah, doesn’t seem to work anymore.

Try setting the latest version of wine, then opening wine configuration, and mark the “hide wine version from applications” checkbox.

I just tried it, and it got rid of the error message about the driver, but then gave me another error message about having activated my game on too many computers.

I’ve got the VAPPI thing on just to try it out, but you might want to leave it off for compatibility.

wine%20staging%20options

Scratch that. Try Wine 4.13, set wine configuration to Windows 10, and that should fix it.

It’s now working on my machine, although I’m using an AMD APU.

-Edit: seems to work with Windows 7 mode set too actually.

Something for all those people who’ve been asking when SWBF2 will work in Lutris :wink:

Here you go! :smiley: Don’t know if anyone else has already been getting this going?

I’m running it on my Ryzen 5 3400G APU at the moment. Unfortunately it crashes when trying to load gameplay, but that may be due to the vram limitation on my APU.

I’ll try it out on another PC, I’d be interested to hear what other people’s experiences running it are.

Looks like some other people have had some luck with it already too:

I’ve set wine to 4.13, and wine config to Windows 7, and DXVK version 1.3.4.

Edit- Actually yeah, with a little tweaking, it works in game even on my APU to some extent.

I’m having a problem with the mouse clicks not working. But we can start another thread for SWBF2 stuff if there isn’t one already.

I got it working a few weeks ago with great performance. The only issue I have are some strange lighting issues in space combat. Specifically when pointed toward/near a star, burning wreckage, etc.

1 Like

Hi! Everybody,

I’m having issues installing Origin, Battefront 1 or Battlefront 2 script. I get an endless list of lines saying:
002b:fixme:netprofm:list_manager_GetConnectivity 0x5e7fb28, 0x33d7c0

Is anyone facing this? Thanks in advance for the help!

What are your CPU, RAM, GPU, and driver specs?