Help with Star Wars Battlefront 2015

Hi guys.
I got Star Wars Battlefront 2015 running in Lutris today, but it has some graphical glitches I’d like to get sorted out.
If anyone can help me with it, I’d be appreciative :slight_smile:

I added the game to the Lutris database here:

You can probably see the screenshots I added from the game.
It’s playable, and I finished a Walker assault ok, although my CPU seems to be struggling to run it, which I’d say is the major thing that’s causing the slowness I’m getting.

I got it to run using wine version tkg-4.0 via the Origin installer, and left DXVK off. When I turn on DXVK, Battlefront throws an error about not being able to determine the Radeon driver version. As it’s spoofing a Radeon card in wine when I turn on DXVK as a part of some kind of nVidia driver incompatibility workaround, even though my card is a Geforce GTX 1060. (Insert Linus Torvalds nVidia quote here…)

I think the graphics would work properly under DXVK, and I tried messing with the wine registry to insert some Radeon driver version strings to try and fool Battlefront, but nothing I tried worked.

So I’m wondering if anyone can help me fool SWBF to think it’s using some kind of up to date Radeon driver, or otherwise bypass the driver detection, so I can just run the game.

Also, I have no idea how to make a Lutris installer for it. So if someone could do that, or show me how, that’d be good.

Nice job getting Battlefront to run!
I think there are some installers that use a dxvk.conf file that will spoof a GPU, if you can’t figure it out need you can add a note to the installer’s technical notes since the current one should be valid for AMD GPUs.

1 Like

First off open an issue here:

Second you could try:

- input_menu:
    description: 'Choose your GPU:'
    id: GPU
    - '#dxgi.nvapiHack = False': AMD
    - dxgi.nvapiHack = False: Nvidia
    preselect: '#dxgi.nvapiHack = False'
- write_file:
    content: $INPUT_GPU
    file: $GAMEDIR/dxvk.conf
    nvapi,nvapi64: disabled

I added this to the script please try these locally.

1 Like

Wow! It works great!
You guys are awesome! Thanks cxf!

Next up I’m going to try SWBF2.

There’s some strange problem that’s been happening with the sound. It’s playing back in slow motion. I’m not sure if it’s been that way since I started running SWBF, it defintely was there before I used cxfs’ DXVK installer. I think probably something in winetricks would fix it.

Other than that, it works really well except for a minor issue with the window taking some wrangling to get it to go into full screen, but once there, it runs well. Standard wine full screen quibbles. Might work better with emulated desktop enabled.

I’ll try it with the Origin overlay on too, I’ve heard that can cause problems, but it’d be cool if it works without any issues.

Ok, a few things I did to get it working better:

I disabled the ‘builtin’ fallback for xaudio2_7, now the audio is playing correctly at the moment.

Next thing is I went into the nVidia driver settings page, and set “override application setting” for anti-aliasing and anisotropic filtering, and set them both as high as I wanted them in game. So now the graphics look like they would on Windows.

The third thing I did, was set the Windowed (virtual desktop) in the runner options of the game, which fixed the issue I was having with not easily being able to maximise the game. However, when I start a map, I have to alt-tab and alt-tab back into the game, in order to get the mouse to drop from being a cursor to being caught by the game to use for aiming the gun.
I suspect if I set the "mouse warp override’ to ‘force’ that it’ll solve the mouse issue. As I’ve noticed that seems to work for many games I’ve had that problem with.

I’m going to make a ‘report issue’ note on the game page, in order to post a link to here, so that people can see what we’ve discussed in relation to getting the game to work best.

Next up I’m going to try SWBF2.

Oooh now this is something I’ve been wanting for a while and tried a few times myself to no avail. I’ll definitely be keeping an eye on this thread.

when i boot up the game i click play in origin and then nothing happens the game doesnt boot

after awhile i messed around in the lutris setings it ended up with saying i need to update my radeon driver for this to work

First off, always make sure you have Origin In-game disabled from the Origin settings. As I haven’t yet been able to run SW Battlefront with it enabled, so I doubt it works.

To fix the issue with the amd driver error at game launch:
Do you have an AMD card or an nVidia card?

You can try renaming up your old prefix, then reinstalling via the Lutris installer, and make sure you select nVidia if you have an nVidia card, or AMD if you have that.

Then copy your SW Battlefront install dir to your Origin games folder in the new prefix so that Origin can rediscover the files instead of having to download them again.

Another problem I’ve had is that the game doesn’t launch full screen properly. Which I solved by going into the Lutris launcher settings, and set; ‘Windowed (virtual desktop)’, under the runner options tab, and set your desktop resolution below it.

hi thanks for your response i am running an amd gpu and i allready selected the amd gpu option in the installer image this is what comes up when i boot the game

this shoud answer enymore questions you have

How are we going on the SWBF2 installer?

Was wondering the same myself. Has anyone gotten that to work?

I can’t even get it to run on either of my Windows machines :stuck_out_tongue: I was on to Origin tech support for around a week, and they were unable to give me a straight answer as to what could fix the problem on Windows 10.

I tried numerous winetricks etc to get it to run in Lutris, and there’s definitely something different about SWBF2 that’s stopping it from running in Wine as SWBF does.

1 Like

Hi everyone! I’ve been trying to run SWBF 2015 on my computer both under PlayonLinux and Lutris. I manage to run the game quite well at both but I’m experiencing stuttering as with no other game I run. I mean, I’ve played Metal Gear Solid 5 with no issues and other demanding games with no problems at all, but SWBF is running with 1 or 2 second “hiccups” every 5 or 8 seconds of playing.

I tried with the original prefix, with wine4.9_staging, with DXVK 0.52;0.96 and 1.21 and with all I have the same issues. I tried enabling Esync on Lutris but nothing gets better. Finally I ran it without DXVK to see if was something transparent to it, or maybe associated with sound (who knows!). Well… with no DXVK off course graphs have glitches, but the stuttering remains. Also, removed the xaudio2.7 override but still the same.

I guess there must be something I’m not nailing, maybe even outside Lutris or Playonlinux, but I have no idea what. Any help or experience will be appreciated!

Ahh, yeah, my system?
KUbuntu 18.04 on a Core i7 laptop. 16GB of RAM, NVidia GTX1060 …and whatever command you may want me to run for diagnose, I’ll be happy to paste here the output.

Thanks again!!

Hi. I’ve been having similar stuttering in The Witcher 3, but not problems in SW Battlefront.

You can try installing “Ubuntu Studio Controls”, from the software center, then open it and tick the box that says: “CPU governor in performance mode”. Which will tell your Linux kernel to ignore your CPU power throttling function, which will result in slightly higher CPU power consumption, but might improve CPU responsiveness.

I read somewhere that Linux often doesn’t handle the CPU power throttling function very well, so for gaming, it’s best to leave it in performance mode.

If that solves your issue, then good, but I’d say it’s a longshot.

Could also be something like your hard drive not responding quick enough when the game loads something, or maybe some background process that’s spiking some component of your PC.

Also I have funny issues with games relating to whether or not the game is running in a “virtual desktop” or not.

You can go to your prefix settings, go to the “runner options” tab, scroll down to ‘Windowed (Virtual Desktop)’, and tick that. Then set your virtual desktop resolution to whatever resolution you want your game to run at.

Sorry just to randomly drop in on this thread; I have been loosely watching for a month or so. But I have a jab:

Who knows, maybe just about the time you get BF 2 to work, EA will release a fully-functional Linux client, like we have been begging them for years. I mean, think of the fortune they could make on telemetry, we are begging them. They just won’t :stuck_out_tongue:

Personally I don’t think SW Battlefront 2 will ever work on Linux. The game seems to be borked. I’ve seriously considered taking EA to the consumer tribunal here in Australia, because I’ve been trying to get my copy of SW Battlefront 2 to work on various different Windows 10 machines for ages, and their tech support have been utterly useless and refuse to escalate the issue to someone who could give me an actual solution to the issue, rather than just a stock standard response that has nothing to do with the issue.

Regardless of whether EA fix the game on Windows, there are many games that will never run on Linux due to digital rights management software and anti-cheat software, which is specifically designed to stop the games from working outside of their intended operating parameters, i.e. running them on windows.

Hi I Added the game in lutris. But unfortunately I can’t login in origin, because it thinks I got no internet connection.
Do I’m miss somthing?

Hi. Yea, that happened to me too the other day.

If you go into the Origin folder in your SWBF prefix, you’ll find a file called ‘’

If you open up a terminal, and do the following:
“cd /insert the/ path to your lutris games/ folder here/star-wars-battlefront-2015/drive_c/Program Files (x86)/Origin”

Where the path is the location of the Origin folder on your Linux file system.

Then check you’re in the right directory by typing: ls (LS, but it has to be lower case letters)

Then you should be able to see a file called ‘’.

What you’ll need to do then is type: ./

For ease, you can just type: “./upd”, and then hit the tab key on your keyboard, and the terminal should try to complete the rest of the word for you based on the files available to run in your current directory.

1 Like