Back to the main site

Help with Star Wars Battlefront 2015

Hi everyone! I’ve been trying to run SWBF 2015 on my computer both under PlayonLinux and Lutris. I manage to run the game quite well at both but I’m experiencing stuttering as with no other game I run. I mean, I’ve played Metal Gear Solid 5 with no issues and other demanding games with no problems at all, but SWBF is running with 1 or 2 second “hiccups” every 5 or 8 seconds of playing.

I tried with the original prefix, with wine4.9_staging, with DXVK 0.52;0.96 and 1.21 and with all I have the same issues. I tried enabling Esync on Lutris but nothing gets better. Finally I ran it without DXVK to see if was something transparent to it, or maybe associated with sound (who knows!). Well… with no DXVK off course graphs have glitches, but the stuttering remains. Also, removed the xaudio2.7 override but still the same.

I guess there must be something I’m not nailing, maybe even outside Lutris or Playonlinux, but I have no idea what. Any help or experience will be appreciated!

Ahh, yeah, my system?
KUbuntu 18.04 on a Core i7 laptop. 16GB of RAM, NVidia GTX1060 …and whatever command you may want me to run for diagnose, I’ll be happy to paste here the output.

Thanks again!!

Hi. I’ve been having similar stuttering in The Witcher 3, but not problems in SW Battlefront.

You can try installing “Ubuntu Studio Controls”, from the software center, then open it and tick the box that says: “CPU governor in performance mode”. Which will tell your Linux kernel to ignore your CPU power throttling function, which will result in slightly higher CPU power consumption, but might improve CPU responsiveness.

I read somewhere that Linux often doesn’t handle the CPU power throttling function very well, so for gaming, it’s best to leave it in performance mode.

If that solves your issue, then good, but I’d say it’s a longshot.

Could also be something like your hard drive not responding quick enough when the game loads something, or maybe some background process that’s spiking some component of your PC.

Also I have funny issues with games relating to whether or not the game is running in a “virtual desktop” or not.

You can go to your prefix settings, go to the “runner options” tab, scroll down to ‘Windowed (Virtual Desktop)’, and tick that. Then set your virtual desktop resolution to whatever resolution you want your game to run at.

Sorry just to randomly drop in on this thread; I have been loosely watching for a month or so. But I have a jab:

Who knows, maybe just about the time you get BF 2 to work, EA will release a fully-functional Linux client, like we have been begging them for years. I mean, think of the fortune they could make on telemetry, we are begging them. They just won’t :stuck_out_tongue:

Personally I don’t think SW Battlefront 2 will ever work on Linux. The game seems to be borked. I’ve seriously considered taking EA to the consumer tribunal here in Australia, because I’ve been trying to get my copy of SW Battlefront 2 to work on various different Windows 10 machines for ages, and their tech support have been utterly useless and refuse to escalate the issue to someone who could give me an actual solution to the issue, rather than just a stock standard response that has nothing to do with the issue.

Regardless of whether EA fix the game on Windows, there are many games that will never run on Linux due to digital rights management software and anti-cheat software, which is specifically designed to stop the games from working outside of their intended operating parameters, i.e. running them on windows.

Hi I Added the game in lutris. But unfortunately I can’t login in origin, because it thinks I got no internet connection.
Do I’m miss somthing?

Hi. Yea, that happened to me too the other day.

If you go into the Origin folder in your SWBF prefix, you’ll find a file called ‘updateorigin.sh’

If you open up a terminal, and do the following:
“cd /insert the/ path to your lutris games/ folder here/star-wars-battlefront-2015/drive_c/Program Files (x86)/Origin”

Where the path is the location of the Origin folder on your Linux file system.

Then check you’re in the right directory by typing: ls (LS, but it has to be lower case letters)

Then you should be able to see a file called ‘updateorigin.sh’.

What you’ll need to do then is type: ./updateorigin.sh

For ease, you can just type: “./upd”, and then hit the tab key on your keyboard, and the terminal should try to complete the rest of the word for you based on the files available to run in your current directory.

1 Like

Thanks. Now the login success, and the install too.
But the game crache by startup with a page fault.
The Wine build: tkg-protonified-3.21-1-g341b86d is the correct one to use?

Try the latest wine version. 3.21 is pretty old now and the installer hasn’t been updated even though Origin and SW Battlefront work well with many newer versions of Wine.

I just started it up successfully using the lutris-4.21 Wine version.

Also tried it with lutris-4.21 - not starting, cause of “Unhandled exception: page fault on write access to 0x7b423ef0 in 64-bit code (0x000000007b423ef0)”. I guess a library is missing or whatever.
I’m giving it up, that’s enough time i spend on it. Downloaded the >50GB 3 times :frowning:

Hmm that’s unfortunate. Maybe your file permissions aren’t set correctly?

You shouldn’t usually need to redownload the game files, if you just move them from your old prefix to your new one, and put them in the origin games folder specified in the Origin settings, then Origin will just check the files for corruption, and re-download only the missing or corrupted files.

One thing that comes to mind is that you might be trying to use an NTFS partition to install your prefix on, which would fail, because the file permissions can’t be set by Linux on NTFS.
You’d need an ETX4 linux filesystem, or some other Linux file permissions compatible filesystem for your games prefixes.

If you want to reuse your existing SWBF files, just make sure you take ownership of their files and set read and write access permissions on them once they’re on an EXT4 or other fully Linux compatible filesystem.

All ext4 and the files permissions are all r/w for my user. So that was not the problem.

Hmm. Scratching my head on this one.
Are you using a 64 bit prefix?

If you want to test it further, you can try using the same wine version in Lurtis with different games, and see if you have errors with those too.

In the console output it says 64bit prefix. The only other game I tried was skyrim. It stars. So I tried to start Battlefront 2015 with ‘Proton 4.2’. The first time it says that there is something with .Net missing. Maybe it is also the problem with the other runner ‘lutris-4.12.1_x86_64’ ?
Please keep in mind, that I’m not familiar with .Net - I just know it something from microsoft

That’s interesting.

There’s a wine component called “Wine-Mono”, which simulates the .Net framework in wine. Wine-Mono is usually supposed to install itself into your prefix when you set it up, but I’ve had lots of instances in the past usually with Playonlinux, where it didn’t install properly.

If you click on your game launcher in Lutris, and then click the winetricks button on the right, and then you can basically follow this video to install or reinstall wine-mono:

Edit:
Actually I vaguely recall that wine-mono may have been replaced by something else and is no longer used. So I could be wrong about the need to install wine-mono. It might be out of date information.

Here’s a link that says wine-mono is still in development though, so not sure:
https://www.phoronix.com/scan.php?page=news_item&px=Wine-4.6-Bringing-Shared-Mono

With wine-mono installed the game is still not starting.

Hmm. Figures, it was a bit of a long shot.
Winetricks will let you install dotnet versions, but I kind of doubt that’ll work.

Actually wait. I just remembered that I had to turn off the Origin overlay in the Origin settings in order to run SW Battlefront.
That could well be the problem.

Oh, yes. The origin ‘overlay’ was the problem :smiley:
I found the button to deactivate it in origin under the game properties of Star Wars Battlefront 2015.
Thanks.

1 Like

Bgah! Kicking myself, it’s the most obvious thing I should have mentioned at the beginning :stuck_out_tongue:

Good that it works!

1 Like

When I try to launch Battlefront I get the error “Detected NVIDIA GeForce driver version 337.88. The required driver version is 358.91 or later.”
I have a GTX 970 with the Nvidia 430.40 driver.
I double checked that the nvapi,nvapi64 is disabled in the runner options.
My dxvk.conf file:
dxgi.customVendorId = 10de
dxgi.nvapiHack = False

I also tried renaming the nvapi64.dll file in windows/system32/, but it didn’t help.

During the installation of Origin (Battlefront 2015 script from Lutris) I choose the Nvidia graphics card option. I also tried the AMD option (didn’t work, too).

I disabled DXVK in the system options (didn’t help).

My system:
Kubuntu 18.04.3 (64 Bit)
Kernel: 5.0.0-23-generic