Back to the main site

GTA V Freeze

Hello,
Recently, I installed GTA V through Lutris Installer script and whenever i start the game, on any key press the game freezes for like 1-2 seconds . Any ideas to solve this ? :slight_smile:

Which installer did you use?

The instructions of the Steam (Windows) Steam w/ DXVK version contains the following remark:

“Limiting your FPS to 60 and enabling V-Sync inside of the game, will solve stuttering problems in most cases.”

Could this be your issue?

Any updates on this? I’m having the same issue.
For me, I noticed my keyboard controls work in the game when the app is not in direct focus (when I’m on my second monitor, but then my mouse doesn’t work). As soon as I give focus back to GTA the keyboard continues to freeze the game.

For me, keyboard works fine in the main menu. It only freezes the game once it starts.

Edit:
Looks like this bug might be related: https://bugs.winehq.org/show_bug.cgi?id=43102

Tried both of solutions to fix that. It doesn’t works :frowning:

Any ideas?

If it’s related to the bug mentioned on winehq, it’s possible an older version of wine may have the patch included (they removed it in newer releases). I’ve tried a few different wine runners now with no success. Very annoying since it “works” for me when not in focus.

Sounds a lot like the issue I was having a couple days ago after installing the Steam w/ DXVK version from https://lutris.net/games/grand-theft-auto-v/
Mouse and Xbox controller were working perfectly but keyboard input froze the game for about 5-10 seconds at a time. I changed my runner from lutris-nofshack-4.18 to winehq staging 4.18 and now everything works as it should.

Ok. Found a solution. I installed GTA V Social Club Version through Lutris Installer script and changed the runner to Proton 4.11 with VSync On . Game is running very smoothly.

Worked for me as well. I was trying a bunch of older runners, just needed the newest one!

1 Like

Extremely new to lutris and gaming on Linux.
I am facing the exact same issue : The game freezes for like a few seconds on key press and works when the focus is out.

The GTA V is installed through Epic Games launcher.

As per the comments I tried to change runner to proton but did not know how to add it as a runner or how to change the VSYNC.

Can anyone please help me make this work step by step.

Same here, I’m also new to lutris but I installed GTA5 through Rockstar Games launcher.
Whenever I press a button on my keyboard the game freezes for 1 to 5 seconds and I can’t move because of this.

I actually was able to change the runner to Proton 4.11 (Right-click the game in lutris -> click on “configure” -> go to “Runner options” -> click on “Wine version” and select “Proton 4.11” -> click on “Save” and start the game), after doing this Rockstar Games launcher started, however as I started GTA5 using the rockstar games launcher the launcher just crashed. I also tried to find V-Sync to turn it on but was unable to find it in the lutris configuration menu.

Since I’m new I sadly have no further ideas what to do but maybe it can help you. If anyone else has any ideas please share them with us

Edit: The keyboard works as long as I’m in the title screen of GTA5. As soon as I start the story mode whenever I press a button the game freezes for 1-5 seconds and all I can do is using my mouse.
The wine version I use (and the only one I tested that works so far) is lutris-6.0-rc1-86x_64, the default one.
Trying Proton 4.11 and Proton 4.21-GE-2 lead to the rockstar games launcher crashing as soon as I started GTA5

Update: After some experiments I found out that the keyboard works in the main menu, but as soon as I start the story mode the keyboard only works in the social club.
It does not work in the pause menu nor in the game.

1 Like

Same issue here, worked fine with 5.x in the past.

I just tried to play the game and as soon as you press a single key in story mode the screen freezes for a few seconds.

Looking at the git releases I can only go back to 5.7, the download options in Lutris have been broken for a few days now.

edit: it seems to work with wine-lutris-fshack-5.7, just do not tab out of the game…

Proton is only way to solve this bug. Use proton or protonified or don’t play.

The bug fix was removed from wine due to some conflict with a random other app somewhere.

1 Like

I 'm interesting by your info source

Same issue here. Game installed from EGS. Wine - lutris 6.0.
When switch wine to earlier version EGS don’t run.

For GTA I use proton by GloriousEggroll. Proton is not supported by Lutris anymore, but if you’ve installed this Proton version according to the guide on GitHub, you can still select it.

Choose Custom wine as runner and type in “~/.steam/steam/compatibilitytools.d//dist/bin/wine” (without quotes and with your Proton folder name instead of my tag) into the custom Wine executable field (you need to have advanced options visible).
This is a workaround until the issue is resolved by developers

1 Like