Back to the main site

Growtopia Fix

Installing Growtopia takes 2 seconds, running it shows ‘No file provided’.

This should be fixed,
I have tried Growtopia with Wine and it doesn’t work perfectly, at first it shows an error from wine but then the game works if you ignore the errors, but when you try to go in the server game the game just freezes and never connects.

I suppose the game might needs some extra things so it would work, and just like y’all did with Epic Games, it would be nice if you also did it with Growtopia.

And make sure accounts dont get banned cause of this reason.

You’re right, it will only takes 1-2 seconds for it to execute. It also does not create a folder on gamedir for some reason

I has able to make it work by doing the following:

Manually download the installer and execute it by:
Right clicking growtopia on lutris.
Then choose run EXE inside wine prefix.
Then select the installer that you download

Then, I performed the following:
Right click growtopia on Lutris
Choose configure
Choose Game Option tab
Change the executable to /home/(user)/.wine/drive_c/users/(user)/Local Settings/Application Data/Growtopia/Growtopia.exe
Change working directory to home/(user)/.wine/drive_c/users/(user)/Local Settings/Application Data/Growtopia/

(user) = your linux account
You can also try browsing the .wine folder and try to manually find it.

It gave me multitouch error, on which I assume because it is trying to detect android multitouch.
Verified that it is working offline. Haven’t tried using GrowID. Hope it helps