Doom 2016 install not working

Doom 2016 install not working it won’t auto start steam & download it & once it’s downloaded & i click on play steam will pop up saying i need a 64bit os & i know for a fact i have one.

Have you checked the discussion here? Doom 2016 working on Ubuntu-Gnome

From My Notes (this happened to me too, but I solved it)

Lutris Improvements
‣ When I clicked install from your website it:
∘ 1/ Installed wine 1.6.2 making (as you now steam login entries greyed out and unusable for most users. I had wine-devel in my computer so it wasn’t from my side.

∘ 2/ It complained that it was not a 64-bit wine version
• and indeed the “Steam Wine” was also set to wine 1.6.2. This can confuse anyone.
• upgrade to a 64-bit version (well now I know it’s needed ONLY in “Steam Wine”, NOT in Wine. This can CONFUSE ANYONE!
• and Perhaps Wine needs to be 32-bit- I still don’t know., but I upgraded it “Wine” to to NON-Staging 2.9 64-bit and all worked well.

∘ 3/ You should (in my opinion) have a users guide - and I sure could have used one, but cold NOT find one ANYWHERE in 20-30 web searches. It could really help!
∘ 4/ Also note that installs in ~/.local/share/lutris/runners/winesteam/prefix and NOT in “prefix64” as one would expect. Perhaps worn newbies about this.

∘ Manage Version
‣ add Wine Staging 2.8 64-bit or most others after 2.0 rc1 (Staging and 64bits is what’s important)

then Wine Steam / Configure
∘ Runner Options
‣ choose 2.8 staging 64 for Doom (change it from System 1.6.2 or what ever your system wine is , … which is likely what over-ruled Lutris’s install of the 64-bit wine staging version)

Good Luck
• Also this makes the blank steam page fixed)

I updated this installer recently. it should work now. sorry for the necrobump.