Back to the main site

Diablo 2 Resurrected get stuck after boot when attempt connection to battle.net

I installed the Battle.net software and Diablo 2 Resurrected.
I managed to start the game and see the first introduction video.
Then, when it is time to connect to battle.net the game freezes
after a minute or two, it stops at all and crashes.
Hope you can help me to find a solution.

V.

1 Like

Lutris Collected Data issue-report and Debug Log

Did you follow all the steps for installing battle.net from the Lutris guide? Also post some details on your hardware, drivers, distro as per the pinned post.

Ehi jhu,

Thanks for replying. In the previous message i out a Ubuntu paste containing information about the system and the version (collected with lutris set in debug mode).

Recap:

Software:

  • linux Ubuntu 20.04
  • vulkan DLL (from GitHub)
  • lutris (latest)
  • installation script (diablo 2 resurrected from lutris site)

Hardware:

  • Intel UHD 620

Note: yesterday i noticed, once in debug, a series of errors while trying to login into battlenet:

  • something referring to secur32
  • something referring to an unknown lpszStructType structure

Perhaps you know how to add the support for these: any change to use wintricks? If so, how?

Thanks

Ok two points: your Mesa is very out of date, and you appear to have missed a few dependencies. Please check this guide for installing battle.net to make sure you have all of the dependencies listed. If this gets through the main login, working out how to update to a more recent version of Mesa will help with in game performance.

Dear Jhu,
I followed all the guidelines and installed the software accordingly.

Here another log of the run.

LOG Lutris

As i said, the game starts but it stops when trying to connect to the battle.net

I don’t reach the menu indeed.

Anything more I can get from my system to help you to address a solution ?

I noticed that people online are able to play such a game from windows under the same hardware specs, but with wine many problems are happening…

P.s. i managed to install latest wine-mono and apparently that solved a few unmatched dependencies. Still the game crashes upon connection to battle.net

Dear Jhu,

I managed to upgrade to mesa-git. Please have a look to the new log.

LOG with MESA-GIT

And this one is with the winehq-staging

LOG with MESA-GIT and WineHQ

Did you execute this from the guide?

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 \
libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

libasound2-plugins:i386 is already the newest version (1.2.2-1ubuntu1).
libgpg-error0:i386 is already the newest version (1.37-1).
libsdl2-2.0-0:i386 is already the newest version (2.0.10+dfsg1-3).
libdbus-1-3:i386 is already the newest version (1.12.16-2ubuntu2.1).
libfreetype6:i386 is already the newest version (2.10.1-2ubuntu0.1).
libgnutls30:i386 is already the newest version (3.6.13-2ubuntu1.6).
libldap-2.4-2:i386 is already the newest version (2.4.49+dfsg-2ubuntu1.8).
libsqlite3-0:i386 is already the newest version (3.31.1-4ubuntu0.2).
libxml2:i386 is already the newest version (2.9.10+dfsg-5ubuntu0.20.04.1).

yes i did it.
I also tried tonight with the latest wine version just uploaded into lutris:

Lutris 6.21 - MESA 22.0

still no success…

Does battle.net complete installation and give you the option to select your region then the login screen during the installation?

Yes, as i said Battle.net works well. I can login perfectly and install the game. Afterwards i can launch the game, see the initial splash screen, the first video cinematics, and then it goes into a freeze as soon it try to connect (from the game) into battlenet

Is this a laptop?

ERROR 2021-11-13 22:20:00,370 [nvidia.get_nvidia_glx_path:42]:Unable to load libGLX_nvidia.so.0
WARNING 2021-11-13 22:20:00,370 [nvidia.get_nvidia_dll_path:90]:Unable to locate libGLX_nvidia

Yes, laptop with Intel graphics.

https://paste.ubuntu.com/p/zWfMBJzZnm/

Check this

In Lutris, go to your Wine Configuration for this game
Screenshot from 2021-11-14 11-08-45

and check what Windows version is selected in the Applications tab

I am stumped, you seem to have everything installed correctly and the logs have a couple of errors I am not familiar with. Maybe post over on reddit in the linuxgaming area?

Was this you? If not, then follow this thread to see a possible solution. Did not know it was borked with intel igpu, I play WoW through battle.net and never had this issue.

Not me but same issues. I got replied on Reddit about this bug in Intel graphics. Very disappointed

Strange issue - do you have any of the other Diablo games? Does your laptop have an amd or nvidia card or just the igpu?

No i just have igpu and my goal is to run diablo for now eheheheh. I will try my best to follow the issue but i am not very optimistic so far.