Cannot play Empire Earth Gold edition

When I use the official lutris script to install the game, it does install but I can not get past the launching it. I tried several options: Switched couple Lutris wine versions, tried changing stuff mentioned in a reddit post.

Also searched previous posts on similiar topics and none of it has a fix for my issue. There is no dsound library in the wine config. Also tried switching targeted windows version several times.

Also tried the neoEE script but it even fails to install with error “FileAlreadyExists”.

Here is a log of trying to run the original game installed by the official lutris install script:

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x00a96fe8).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:00a96fe8 ESP:0032fc8c EBP:0032fd5c EFLAGS:00010246(  R- --  I  Z- -P- )
 EAX:00000000 EBX:00000000 ECX:00000000 EDX:00000000
 ESI:00919344 EDI:00000000
Stack dump:
0x0032fc8c:  005393b5 00000000 008a5ef0 00010000
0x0032fc9c:  00b0e079 00b2640c 00b26770 00f953c8
0x0032fcac:  00000002 00000100 00b26770 00f95518
0x0032fcbc:  00000012 00000100 00b26770 00f95668
0x0032fccc:  00000000 00000100 00000001 00000000
0x0032fcdc:  7ea53f00 00000000 00000000 0032fd0c
=>0 0x00a96fe8 EntryPoint+0xffffffff() in low-level engine (0x0032fd5c)
  1 0x005361bf EntryPoint+0xffffffff() in empire earth (0x00b0df8d)
  2 0x418c15ff (0x006a006a)
  3 0x0000ad87 (0x0f56f883)
0x00a96fe8 EntryPoint+0xffffffff in low-level engine: movl	0x0(%ecx,%eax,4),%eax
Module	Address			Debug info	Name (31 modules)
PE	  400000-  a82000	Export          empire earth
PE	  a90000-  bc0000	Export          low-level engine
PE	10000000-100e4000	Deferred        sxlrt233
PE	7b020000-7b03c000	Deferred        kernelbase
PE	7b420000-7b5f1000	Deferred        kernel32
PE	7bc30000-7bc47000	Deferred        ntdll
PE	7c9c0000-7c9c6000	Deferred        uxtheme
PE	7d360000-7d365000	Deferred        winex11
PE	7d430000-7dd2c000	Deferred        shell32
PE	7dee0000-7dee7000	Deferred        iphlpapi
PE	7df10000-7df17000	Deferred        ws2_32
PE	7df40000-7df47000	Deferred        wsock32
PE	7df60000-7df6a000	Deferred        aclui
PE	7df80000-7df92000	Deferred        shlwapi
PE	7dff0000-7dff4000	Deferred        usp10
PE	7e040000-7e096000	Deferred        comctl32
PE	7e190000-7e19c000	Deferred        dinput
PE	7e1f0000-7e270000	Deferred        winmm
PE	7e2e0000-7e30d000	Deferred        ole32
PE	7e430000-7e43e000	Deferred        gdi32
PE	7e580000-7e58d000	Deferred        rpcrt4
PE	7e630000-7e724000	Deferred        user32
PE	7e840000-7e846000	Deferred        shcore
PE	7e880000-7e88d000	Deferred        advapi32
PE	7e920000-7e948000	Deferred        ucrtbase
PE	7ea20000-7ea35000	Deferred        msvcrt
PE	7eb10000-7eb51000	Deferred        msvcp60
PE	7ee10000-7ee16000	Deferred        imm32
PE	7ee30000-7ee35000	Deferred        version
PE	7ee50000-7ee69000	Deferred        setupapi
PE	7eed0000-7eed3000	Deferred        wow64cpu
process  tid      prio (all id:s are in hex)
00000008 (D) C:\GOG Games\Empire Earth Gold\Empire Earth\Empire Earth.exe
	["C:\GOG Games\Empire Earth Gold\Empire Earth\Empire Earth.exe"]
	00000009    0 <==
	00000033    0
	00000036    0
0000000e services.exe
	0000000f    0
	00000010    0
	00000021    0
	00000028    0
	0000002d    0
00000013 explorer.exe
	00000014    0
	00000015    0
	00000016    0
	00000017    0
	00000018    0
0000001f winedevice.exe
	00000020    0
	00000022    0
	00000023    0
	00000024    0
	00000025    0
00000026 plugplay.exe
	00000027    0
	00000029    0
	0000002a    0
0000002b svchost.exe
	0000002c    0
	0000002e    0
	0000002f    0
00000037 explorer.exe
	00000038    0
	00000039    0
	0000003a    0
	0000003b    0
System information:
    Wine build: wine-5.7.r0.g2ad422ff ( TkG Staging Esync Fsync )
    Platform: i386 (WOW64)
    Version: Windows 10
    Host system: Linux
    Host version: 5.18.16-zen1-x86_64

Well from what I understand it is trying to read memory at the 0 pointer which it should absolutely not be doing…

1 Like

maybe this will help you: