Can’t launch wow

Hi when i try to open world of warcraft with Lutris, with the report ID :


What can i do ? i unstalled Wow and install it again, but it still not workin !

1 Like

Hello, i have the same problem. Can anyone please help?

1 Like

You need to try installing wine-staging of 5.19.
I was having the same problem
I have 5.20 and i t seems to work fine for me. The only issue is the bnet client being really slow to load up and allow me to launch.

this site gives a pretty thorough run down of how to do it for a few different distros.
worked for me

Hi, thank you for the suggestion. I already have wine-staging 5.20 installed since it was needed to fix a bug in the game 2 weeks ago. But the game stopped working 3 days ago while i already had wine-staging 5.20 installed, so i am not sure what to do. Should i try and downgrade my wine-staging version to 5.19? I am a bit confused which version do you currently have that works for you. I would appreciate it if you can let me know.

How can i install wine-staging 5.20 please ?

Hey, this link solved my problem:

I hope it helps you too! :slight_smile:


Hello kiborg,
i didn’t understand when you said : Wine 5.19 & 5.20 DXVK 1.7.2L-5ca255d Nvidia 455.28
So finally how did solved that ? what’s in the link you posted ? :confused:

Hi guys i have same problem where runs fine, i can start the game and see a startup video. right after that the game crashes with that popup screen for bug report. Been trying to get it to work all day.

Im a real newbie at linux still btw. Just changed from Windows 10 to Manjaro linux few days ago. Could you post commands or places i can check to update a specific Wine version and DXVK pls. I dont know how to.

Also if you know, do i have to change settings in the Lutris client for WoW as well?

  1. Use lutris-wine 5.21

  2. launch WOW with dx11legacy option.

More details here: