Back to the main site

Borderlands 3

after 5 to 10 minutes it does

@Anonymous 5 -10 minutes may have to do with your HW/drivers… I’ve got a fairly new gaming lappy (i7-9750/RTX2060 etc) and for me it is pretty much the time it should have taken to play the actual videos.

I wonder if there is some engine setting to force UE4 to use some other codec/format … read something about Overwatch and forcing it to software rendering and WEBM instead of MP4. Maybe the same could be done here. I’ll see if I get some time to dig around.

Can this website give anyone any ideas? https://docs.unrealengine.com/en-US/Engine/MediaFramework/HowTo/index.html

@GlennSteenn I can play around with modifying the codec. I will need to look further at the Unreal documentation and see if codec/container matters on an engine level, or if it just sends the asset out to whatever external .dll handles that codec.

Also I looked at the Overwatch installer and the only switching to webm I see is that it switches the mode of saving gameplay clips to webm and disables hardware acceleration for it. So unfortunately I don’t think that will help either. Unless I am missing something in the installer, or the info is from another source, which could easily be.

@steve7253 I will take a look, hopefully I can get an idea of how it handles media assets at the very least.

Before dig deep into hacking codec the best way to address our issue is to get in touch with the author who knows more of “mf-install” and how it works.

I’ve opened a new issue on GitHub asking the author to have a look into this. Hopefully he can and will add the mpeg4 to his package - or he may give us some clues how to get over this issue.

1 Like

Good call.

@MR1865 Did you try the other method (mf-installcab), referenced from the mf-install github readme?

I’m a bit leary tinkering with something that mostly works, limping along with the help of both the matchmaker method (which is annoyingly random, and may inadvartently advance you too much in the story) and the savequit thing. Seems gearbox has littered with these annoying “watch the video” things… and they seem to fail on other platforms too, including wimdoze. One could hope for an easier “story advance/reset” mechanism, like for the oh so buggy ol’ Skyrim:-).
But if yu think it might help, I might have a go at it.

I commented on your new GitHub issue so they have a better idea of what is going on. Or not going on depending on how you look at it. :grinning:

Edit that was supposed to be a reply to MrGazza. I must have clicked the wrong reply button.

I dont know if that is the same for you guys, i’ve installed borderlands without any problems and it started too, but after closing the game or restarting/shutdown my pc my game wont run anymore and when i start the game ive got a error-message from codefusion to solve a problem.

Thats weird.

@GlennSteenn I have not tried the other method, though i probably should for completeness. I can do so. If you are worried about breaking the install, I can post the unpublished install script I wrote. I have used it several times and it works on my system. If you are worried about losing save data, you can copy out the save data from the Wine Prefix and copy it into the new one. I have done it multiple times during testing. Especially since the cloud save function in the Epic Games store is awful.

Update: Made an installer which uses the mf-installcab stuff instead, does not work at all. The reason I hadn’t tried it yet was because it looks like the mf-installcab is listed to work on some RE Engine Games, and the mf-install script seems to work mostly with Unreal 4 games. Worth a shot, but unfortunately no dice.

@elika123 Are you launching the Borderlands 3 executable directly? Or are you launching through the Epic Games store? If I remember correctly, that error may be DRM related (yay…) I think it may just be that you need to launch the game through the Epic Games store for it to work. If you are launching through the Epic Games Store, we will need more info to be able to help.

I’ve come across some solution for other games of which this one seems promising:
https://lutris.net/games/install/10999/view

I may try adding this with the epic games store install script throughout the weekend - though I need to educate myself about Lurtris installers first

My first crack at an installer used that. It did not work. That is why I moved to the mf-install method. Although I just had a realization. The Gris installer was what I used as a template. One uses x32, the other uses x64. I think I need to retry using some of the x32 dlls and see how it works.

I will take a look at it.

Update: I made an installer with the mfplat dlls both 64 and 32 bit. It did not seem to fix the issues that mf-install does. I could have missed something necessary in the installer, so if someone else wants to take a shot at it feel free.

If you have an Nvidia card and updated your driver to one of the later ones (>415 I think), there’s a bug regardng some json files that vulkan needs. Running vulkaninfo as root will resolve it until reboot, so on my Ubuntu based system I start every session with a simple “sudo vulkaninfo”. Works nicely after that.

Any further info on this? I am running a GTX 1070 with the 430 drivers with no issue.

i have a 2080 ti and i7 7700 non k and 31.4 big of ram I’m also having a another issue after completing a mission and going on the next one it would not start until i exit the game and open it again this takes a while for it to happen i do not no why.

Ah sorry, yes. I’m running on a RTX 2060. Updated the drivers via the usual measures…Well, really, did an update of the OS (Ubuntu Budgie went from 18.04.2 to 18.04.3, kernel 4.18 to 5.0)… and that seemed to break the driver (it had gone from 415 to 418)… Did a metric tonne of troubleshooting why suddenly all dxvk-games stopped working, and opportunistically updated the driver a few times. Currently running at 435.
So it might be any number f factors, from GTX<>RTX, kernel version etc why you see no issue and I need that fix.
Basically running vulkaninfo will give you something like:
glenn@glenn-TUXEDO:~$ sudo vulkaninfo
[sudo] password for glenn:
WARNING: [Loader Message] Code 0 : loader_icd_scan: Can not find ‘ICD’ object in ICD JSON file /usr/share/vulkan/icd.d/nvidia_layers.json. Skipping ICD JSON
… lots of output
and it will recreate the missing ICD json file.
After that Vulkan, and hence DXVK and all that depend on it, like wine, are fine.

Strange, so it loses this on every boot? I am not going to be much help with troubleshooting as I am running Gentoo. I will note though, that I have had a ton of problems with the 5.0 kernels. I rolled my system back to 4.19 after using 5.0.X for a couple of weeks as it was extremely buggy on my system. If you still have the old kernel in your grub entries, I would be curious to see if booting the old one changes anything.

Thanks, hoped it would solve the issue

I haven’t tried this yet but maybe we just didn’t install everything but this might work as it is a bit more.

1 Like

Thanks a lot for the video, good find!
I’m… was about to try the solution in the video but…

Currently your game purchase cannot be re-validated successfully, please wait 24 hours and try again.

I wish some nice stuff for the one that implemented this.

Anyway, regarding the video,

  • I was able to run the game WITH esync ON from the beginning.
  • The registry entries were all there for me already - may have been added by the winetricks:mf package I’ve installed earlier

Hopefully can try the game soon… in 23 hours or so.