Back to the main site

Borderlands 3

Hey

i installed the Epic Game Store with the Lutris installer.


then downloaded and installed Borderlands 3.
Startet it and it runs Perfect in the Main menu but when i click on “New Game”
it compiles shader and then nothing. (waited 3 hours)

has anyone the same issue or any an fix for it?
or how can i see the output from wine?

I believe it is related to media foundation issues. The mf-install project should help. Just run the shell script with the wine prefix for your epic games install and the game will start. However the game appears to have issues playing mp4 files, so some assets (like the marcus intro movie) will not play. This is not a huge issue in-game, but will break one of the early objectives in the game. I am working on an installer specifically for the game that should set mf-install up automatically. Though it is my first installer, so no promises on quality. I am also looking to see if I can find a fix for the mp4 issue, will report back if I come up with anything.

edit: If anyone with more experience than I wants to take a crack at it, please do. I am not experienced with wine and can use any suggestions I can.

I just completed install it to my Satisfactory prefix and the splash screen appears then a blank black screen and at the bottom right it says ‘compiling shaders’. After a minute or so the words go away and nothing just a blank black screen and no sound. I waited several minutes then killed the process.

Is this after having properly installed the media foundation libraries from mf-install?
Also, the initial load takes forever for me. I think part of this is the mp4 error I was referring to before, so it cannot load the splash screen videos for 2k, Gearbox, and AMD.

MR1865 im not seeing how to install mf-install?

git clone https://github.com/z0z0z/mf-install
cd mf-install
WINEPREFIX=<path to game install directory> ./install-mf.sh

Replace the bracketed stuff with wherever the epic games store install is.
This is assuming you have all the appropriate WINE dependencies already set up for the Epic Games Store and that is already working.

1 Like

Thank you MR1865, that kind of worked… Apart from Liliths “speak in head” animation coming out black, and the story mission … halt, that you mentioned (at least if you by that mean something invoving a very large oldschool CRT display).
AFAICT the windows media player is installed, but they might be using something else, some codec not in place… Any ideas?

Yes, that is exactly the issue I am talking about, with the “Watch the monitor” objective. It appears to be an issue with Unreal 4 games in general. I have tried a number of things to fix it with no luck thus far. I will post on here if I come up with a fix.

As far as getting past that section in the game, if you play with someone else as the host (not in Linux), the objective will complete fine. Then after that you are clear, haven’t run into any other blocking bugs yet. I also managed to get past it in testing by quitting and going back into the game a couple of times while at that objective. Didn’t fix mp4 playback, but got past the objective. Though that seemed like a fluke so no guarantees.

Also the “speak in head” animation does not come out black for me. It is more like white static. Not sure if that is hardware or driver specific or anything. Also not sure what it is supposed to look like in a working install.

Edit: Looks like that not showing up is the same mp4 loading issue as everything else. Luckily those don’t cause an issue otherwise.

Ah, yet another set of good tips!
Since I lack any windows-toting BL3-playing friend, that option was out.
However, after quiting/restarting a large number of times, I think I understand how the advance-quest-gltch works… If you manage to press escape just before the quest objective get displayed (basically just when the load screen goes away), the quest will advance the next time you load in. This needs further testing, but may serve someone else, if they are stuck.

Againg, thanks for the legwork MR1865!

Thanks for the share of your investigations. Also had the tv bug and just joined a different lobby with MM. Currently the mission ‘cult following’ seems bugged. I just can’t hand it in and am trying to join different lobbies to do it again.

hate it any way to debug the game?
or see the console output?

also sanctuary when returning to the bridge does not proceed

Is this just the first time on Sanctuary? I have only played that part in multiplayer with a friend on Windows. It may be the same MP4 issue. I have a memory of something not playing there.

I still have not been able to solve the MP4 issue at all, I have tried a number of different fixes to no avail.

And @GlennSteenn, thanks for the info. I will try that on a character I got to that point to test the issue. See if that works. I triggered it once, but have not been able to again with a different character.

You can see some output from WINE if you run Lutris from the command line. Apparently you can get more verbose output from UE4 by adding some options to the Engine.ini file. But editing

/users/username/My Documents/My Games/Borderlands 3/Saved/Config/WindowsNoEditor/Engine.ini within the wine prefix didn’t help as it seems to be rewritten as soon as the game is started. Though I have zero Unreal Engine (4 or otherwise) experience in terms of debugging, so it may be otherwise possible to get debug output.

Edit: I have written an installer that performs the mf-install steps for you, it is submitted and waiting for approval. The initial one I published does work or fix the problem, so if you go to the Borderlands 3 page (need to show unpublished games via search) and try to the installer it will NOT work. It is an old version I was testing. I will update this post once the current version I have is published.

I can not get mf to install. Kubuntu 19.04.

*steve7233@steve7233-Z68XP-UD3:~$ git clone https://github.com/z0z0z/mf-install

Command ‘git’ not found, but can be installed with:

sudo apt install git

steve7233@steve7233-Z68XP-UD3:~$ sudo apt install git
[sudo] password for steve7233:
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
git-man liberror-perl
Suggested packages:
git-daemon-run | git-daemon-sysvinit git-doc git-el git-email git-gui gitk gitweb git-cvs git-mediawiki git-svn
The following NEW packages will be installed:
git git-man liberror-perl
0 upgraded, 3 newly installed, 0 to remove and 10 not upgraded.
Need to get 4,969 kB of archives.
After this operation, 33.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu disco/main amd64 liberror-perl all 0.17027-2 [26.6 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu disco/main amd64 git-man all 1:2.20.1-2ubuntu1 [835 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu disco/main amd64 git amd64 1:2.20.1-2ubuntu1 [4,107 kB]
Fetched 4,969 kB in 5s (1,088 kB/s)
The system does not support apt-btrfs-snapshot
Selecting previously unselected package liberror-perl.
(Reading database … 246730 files and directories currently installed.)
Preparing to unpack …/liberror-perl_0.17027-2_all.deb …
Unpacking liberror-perl (0.17027-2) …
Selecting previously unselected package git-man.
Preparing to unpack …/git-man_1%3a2.20.1-2ubuntu1_all.deb …
Unpacking git-man (1:2.20.1-2ubuntu1) …
Selecting previously unselected package git.
Preparing to unpack …/git_1%3a2.20.1-2ubuntu1_amd64.deb …
Unpacking git (1:2.20.1-2ubuntu1) …
Setting up liberror-perl (0.17027-2) …
Setting up git-man (1:2.20.1-2ubuntu1) …
Setting up git (1:2.20.1-2ubuntu1) …
Processing triggers for man-db (2.8.5-2) …
steve7233@steve7233-Z68XP-UD3:~$ git clone https://github.com/z0z0z/mf-install
Cloning into ‘mf-install’…
remote: Enumerating objects: 48, done.
remote: Counting objects: 100% (48/48), done.
remote: Compressing objects: 100% (48/48), done.
remote: Total 149 (delta 23), reused 4 (delta 0), pack-reused 101
Receiving objects: 100% (149/149), 8.06 MiB | 1.16 MiB/s, done.
Resolving deltas: 100% (62/62), done.
steve7233@steve7233-Z68XP-UD3:~$ cd mf-installcd mf-install
bash: cd: too many arguments
steve7233@steve7233-Z68XP-UD3:~$ cd mf-install
steve7233@steve7233-Z68XP-UD3:~/mf-install$ WINEPREFIX= ./install-mf.sh
bash: path: No such file or directory
steve7233@steve7233-Z68XP-UD3:~/mf-install$
steve7233@steve7233-Z68XP-UD3:~/mf-install$ WINEPREFIX=~/Steam1/Steam for Windows (Lutris)/satisfactory ./install-mf.sh
bash: syntax error near unexpected token (' steve7233@steve7233-Z68XP-UD3:~/mf-install$ WINEPREFIX=<~/Steam1/Steam for Windows (Lutris)/satisfactory> ./install-mf.sh bash: syntax error near unexpected token(’
steve7233@steve7233-Z68XP-UD3:~/mf-install$ WINEPREFIX=</home/steve7233/Steam1/Steam for Windows (Lutris)/satisfactory> ./install-mf.sh
bash: syntax error near unexpected token (' steve7233@steve7233-Z68XP-UD3:~/mf-install$ WINEPREFIX=/home/steve7233/Steam1/Steam for Windows (Lutris)/satisfactory ./install-mf.sh bash: syntax error near unexpected token(’
steve7233@steve7233-Z68XP-UD3:~/mf-install$ *

Nevermind. I figured it out. After I posted I looked at the output again and immediately spotted the problem. :man_facepalming: Computers are so literal.

The game plays now. I noticed on git hub that the mf project appears to only work with mpeg2. Maybe we have to wait for them to figure out mpeg4. Probably need some dll files that might have copy write issues. I am sure given time the Linux gaming community will figure out a solution. I know from twitter that epic games wants their store and games working on Linux first with wine/Vulcan/proton then I think natively but probably a bit down the road if they go native… We can hope sooner rather than later but I am sure they will think about it a while since native is a huge business decision and will probably involve outsourcing maybe to Aspyr. They mention Aspyr on their twitter comment. They didn’t say anything for sure about going native but the wine stuff is for sure!

i can play Borderlands 3 but after loading it slows down i just think it is compiling shaders i an on manjaro /arch Linux https://drive.google.com/file/d/17_skYjM1y67JgqC_b8mar_YqEx8VqsVc/view?usp=sharing

That could just be the mpeg 4 files trying to play. Does it speed up again later?

also the mission ‘The impending storm’ cannot be started. Which should be done by talking to lilith but no interaction is available. Tried relogging a couple of times but no luck so far.