Battlenet Launcher no longer works

Up until yesterday the bnet launcher and Diablo IV were running without issue. Suddenly today the bnet launcher will not start. I have tried different runners without any success. The only thing that has worked is doing a fresh install of the bnet launcher and using it on its initial launch, it will not launch again after that. I tried to upload the .json file from the lutris --submit-issue command but the file extension is not allowed.

I am running Arch and KDE. System specs are in the link along with the debug log.

System specs and debug log

1 Like

No one else is having trouble with Battlenet?

Installed the flatpak version of Lutris from the KDE Discover app and everything works perfectly. No idea why this is the case but the package manager version seems to be broken as of right now.

I know this is not particularly helpful but I’ve had no trouble with Bnet and Lutris.

However i’m using a manually installed version , not part of any package or anything like flatpak.

I did notice that I would have some weird issues with it, in particular it wouldn’t remember my login, when my VPN was active.

Turned off the VPN and everything was good.

I run Lutris and Bnet on two Arch Linux systems, both installed from the pacman package manager and my main system with KDE and Nvidia card have had 0 issues, strangely my AMD graphics system that I use for couch gaming was the one with this issue. I spent a lot of time bouncing back and forth between systems and checking my settings, comparing and still unable to understand what is happening here, or why the flatpak version of Lutris works without issue on my AMD system.
I tried uninstalling and reinstalling Lutris and Bnet multiple times, cleari ng config files etc, same behavior every time. Yet on my Nvidia system running the same version of Arch Linux with the Zen kernel and same version of Lutris, no issues at all.

Yeah I asked the exact same question earlier. Even posted the system specs and the Lutris-d output.

Nobody answered

But here is an answer from Reddit

Looks like there’s a typo in the script that runs, maybe. Seems to be calling “egedit.exe” instead of “regedit.exe”

It seems Whom so ever made the install script made a typo

I looked at the script and am not able to find where this mistake sits.

Please script writer. See my reply and do a fix.

We would apreciate muchly

Yeah im pretty underwhelmed with the help I have received here as well. I am currently playing around with bottles so I wont need Lutris in the future since it seems to be dead. Are you running KDE? If so, try the version on the Discover store.

OK. I downloaded the installer
Then a simple right click and install Then point to where I want it installed.
Starcraft 1 and 2 installed without incident
Runs without any problems.
Overwatch can be launched from Steam
no problems

Thats great, I am assuming you’re using the flatpak then?

nope. just got it directly from battlenet

Im talking about the Lutris client.

I installed the lutris client from the repository

On my AMD machine, I am still having the same problem with the Lutris package from my Distro’s repo. The flatpak works. On my Nvidia machine, I am using the same version from my repo and it works without issue. Very frustrating.

I was experimenting and found that I could run the battlenet installer through steam with Proton by adding it as a non steam game, then after installing I was able to add the Diablo IV Launcher.exe to steam as a non steam game from the prefix it creates and launch it that way, completely eliminating my need for Lutris on either machine, and it actually runs better that way for me.

1 Like

I ran into the same issue and it was because I did not have the 32bit versions of libraries that Lutris needs. I followed the instructions on the wiki and it started to work for me.

I went through the wiki and scoured Google before posting on the forums. One of the first things I addressed was the 32 bit libraries, and there was no issue. I don’t forum post until I am genuinely lost on what to do next. I’ve been able to install a number of games and launchers through steam using proton and it has been much smoother that Lutris. I still have Lutris installed for some games I had previously played and just haven’t gone back and installed through steam yet. Once I do, I won’t need Lutris for anything.

What version of Lutris are you running (about lutris)? had an update that broke it on linux, but a few tweaks later and wine-ge8-25 along with a dll override had it working again - if you aren’t running 0.5.14 lutris, you should look at updating to this, then set the vulkan ICD loader on preferences → global options → enable Advanced to match your GPU and NOT say unspecified. Finally, rename ~/Games/battlenet folder if it exists and reinstall from the new scripts on - You can use locate game in the BNet launcher to add back your games.

This was months ago, and I’ve since found a solution where Lutris is no longer needed. Thank you for the reply, that might have been helpful back when this was posted. I appreciate the information.

Will leave it here for the next person who stumbles along with BNet issues - still relevant in Jan 2024, who knows when the next BNet release will drop and break something again…

And what exactly was your solution? Since I don’t use Lutris I (and maybe other people) would like to know too.