Battlenet Launcher no longer works

In steam, use WINE_SIMULATE_WRITECOPY=1 (+ any others) %command% in your launch options with the latest GE Proton or I think Proton Experimental also works (haven’t checked in a few weeks)

So playing WoW for example is okay with Steam and Proton nowadays?
I have always used wine-staging for bnet + WoW before.

Hello Lutris Forums.

I sucessfully installed wine/lutris/battlenet on 2nd Jan 2024, with the prerequisite dependencies via the terminal with repo recommened

I have been playing overwatch up to today without issue, until today i run BattleNet and overwatch required an update,
now clicking launch game, does nothing and game appears to crash. Overwatch window never appears.

I followed OJ1 advise, but now BattleNet application crashes on Overwatch launch.

Scan and repair of Overwatch files, nothing

Fresh install of Overwatch, nothing

Tried wine proton, nothing

Tried reboot, nothing

“wine client error:534: write: Bad file descriptor” → happens when battlenet has logged in
“wine client error:264: write: Bad file descriptor” → happens on launch of Overwatch

Wine Log

Started initial process 125850 from /home/nuzicx/.local/share/lutris/runners/wine/wine-ge-8-25-x86_64/bin/wine /home/nuzicx/Games/battlenet/drive_c/Program Files (x86)/ Launcher.exe
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
Initial process has exited (return code: 0)
wine client error:534: write: Bad file descriptor
wine client error:264: write: Bad file descriptor
Monitored process exited.
Exit with return code 0

System Stats

OS: Debian GNU/Linux 12 bookworm
Arch: x86_64
Kernel: 6.5.0-1mx-ahs-amd64
Desktop: XFCE
Display Server: x11

Vendor: AuthenticAMD
Model: AMD Ryzen 7 5800X 8-Core Processor
Physical cores: 8
Logical cores: 16

RAM: 31.3 GB
Swap: 6.0 GB

Vendor: NVIDIA Corporation
OpenGL Renderer: NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 525.147.05
OpenGL Core: 4.6.0 NVIDIA 525.147.05
OpenGL ES: OpenGL ES 3.2 NVIDIA 525.147.05
Vulkan Version: 1.3.250
Vulkan Drivers: NVIDIA GeForce RTX 2080 Ti (1.3.224)

OS: MX-23.1
Lutris: 0.5.14
Wine Version: ge-8-25 and proton
Nvidia proprietary drivers

Next Steps for Me

I will try flatpak
Update: Flatpak worked

You can, just make sure you check if you need the WINE_SIMULATE_WRITECOPY=1 for BNet to launch - last year wine-staging had some performance deficits over using proton (mostly around dxvk and vkd3d). Personally I use proton-ge-8-27 (latest on steam) or ge8-25 on lutris with dxvk 2.3 and vkd3d 2.11.1 (these are not the winehq versions, but included in GE’s proton build, in lutris or you can download from the git pages)

1 Like