Back to the main site

Battlefield 4 via dxvk - also with multiplayer?


#1

Hi folks!

I saw that the new WINE version has some BattleEye fixes in it and there is a Lutris installer for BF4 now. Did somebody already try playing it in multiplayer? Did it work?

Any workarounds necessary because of the battlelog-browser-game link?


#2

Im trying to get it running, but im stuck at “inavlid license missing dxgi.dll”


#3

Yes , I played multiplayer on a server . But the script do not work . I have bf4 installed . Medium settings 1080 with 60 fps .


#4

i had to change my /usr/share/vulkan/icd.d/nvidia_icd.json
from this
{
“file_format_version” : “1.0.0”,
“ICD”: {
“library_path”: “libGL.so.1”,
“api_version” : “1.0.65”
}
}

to this

{
“file_format_version” : “1.0.0”,
“ICD”: {
“library_path”: “libGLX_nvidia.so.0”,
“api_version” : “1.0.65”
}
}


#5

After downloading, but when installing any Origin game, it gives me this error:

https://i.imgur.com/bJNmWkJ.png

Is this a known problem and how to fix it?


#6

You have to have the very latest drivers if you have Nvidia it’s the 390.48 or later I think


#7

I’m already on them:

$ yay -Qs nvidia
local/nvidia 390.48-2
    NVIDIA drivers for linux
local/nvidia-settings 390.48-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 390.48-1
    NVIDIA drivers utilities

Anything else I might be missing?


#8

remove all the “.cab” files in:
/home/USERNAME/Games/battlefield-4/drive_c/Program Files (x86)/Origin Games/Battlefield 4/__Installer/directx/redist


#9

Lead me to this error: https://i.imgur.com/0Vcu74j.png


#10

strange, mine worked fine after i removed those files. did you leave these files alone ?
https://s14.postimg.org/jbn5h4tvl/Screenshot_from_2018-04-05_00-29-52.png


#11

This seemed to be the problem. I now just ran a rm *.cab and it’s installing (“finalizing…”) now without these errors.

Though this time finalizing took an unreasonable amount of time. I uninstalled BF4 once again and redownload it. As it downloads the CAB files pretty early, I already deleted them. Hopefully it will now install correctly :slight_smile: I’m reporting back, but downloading this little game will take some time for me :smiley:


#12

And it Will download the cab files more than one time while you install bf and its expansions, I think I removed them 3 times :joy:


#13

I have Origin installed, but when I want to install BF4, I can’t reach the installation button at the bottom and virtual desktop is locked at 800x600. I tried to disable the virtual desktop and even resize it, nothing works. I have Battlefield 4 Premium.


#14

Yeah. Also my Origin randomly hangs. I can still move the window around and mouseover effects from the top menu happen, but the whole menu doesn’t refresh and remain where it was. So I have to restart it about every 30 minutes and then remove the CABs again. <.<

Open the winecfg of this prefix and set another size for the virtual desktop :slight_smile:


#15

@Trollwut @Norrox Was having the same, problem, DirectX failed to initialize.

Attempting the fix now, if this works, it could be considered the confirmed fix. yea?


#16

For me, I still can’t start. :confused:

My steps for now:

  1. Installing Origin via Lutris
  2. Setting Wine version to staging-3.5
  3. WINEPREFIX=~/Games/origin/ setup_dxvk64 (via AUR package on Arch)

I then moved the whole folder to another disk and symlinked it to ~/Games/origin/, as BF4 needs an unreasonable amount of available disk space. This worked for any other game, so I don’t think that’s the problem. If I don’t do this (with about 90 GB free space), the installation of BF4 doesn’t finish. No error, no nothing, it simple doesn’t come to an end (after several hours).

  1. Downloading and installing BF4. (I deactivated DLCs to have a faster result)
  2. That DirectX error shown earlier
  3. cd ~/Games/origin/drive_c/Program Files (x86)/Origin Games/Battlefield 4/__Installer/directx/redist && rm *.cab
  4. Now installation finishes!
  5. Starting the game and just get this error: https://i.imgur.com/o2YGkFf.png

How should I proceed now? :frowning:


#17

@Trollwut Lutris will just ignore that and reset it to what’s configured on Lutris.

@PlutonMaster You can change the default resolution globally for Lutris like this:

You can also change it on a per-game basis: Right-click game > Configure > Runner options


#18

That’s because BF4 uses a patched dll that’s not on the main DXVK repository yet.

This is where I host them for the BF4 installer:

https://github.com/AccountOneOff/lutris_files/blob/master/d3d11.dll

https://github.com/AccountOneOff/lutris_files/blob/master/dxgi.dll


#19

Unfortunatelly the same error for me :frowning:

I removed the symlinks of the two DLLs in C:\Windows\system32\, which have been created by setup_dxvk64.sh and put your two DLLs there instead

Did I miss something?

My library tab of this WINE: https://i.imgur.com/qeURgEl.png

EDIT: Also placed the DLLs into the game’s directory (bf4.exe) and it’s the same error :confused:

EDIT2: Also, because you mention it in the BF4 installer script:

$ cat /usr/share/vulkan/icd.d/nvidia_icd.json
{
    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "libGLX_nvidia.so.0",
        "api_version" : "1.0.65"
    }
}

#20

Try reboot