Back to the main site

Battlefield 4 via dxvk - also with multiplayer?


#21

Thanks. Now I’m installing BF4 and then try this out.


#22

Nope, still the same error

I fired up Origin in a terminal and this is the output when I start Battlefield4: https://pastebin.com/rDGNQRUF

BF4 is being started at about line 730, the process itself is being shown at line 953, crashing half a second after that


#23

Remeber , A few maps works good ,. other the graphic is fup after you died . Restart punkbuster berfore you start the game. In Lutris run exe file inside wine prefix . Then go in battlefield 4 folder undet installs i think and reinstall . Windows 10 had the same problem . If you get kiccked out restart punkbuster ,.


#24

absolutely no luck on my end, i do not get an error message anymore. Battlefield acts as though it is installed, and ready to play. When I press play however, the cloud save feature pops up and completes, but the game never launches


#25

Have you set up your vulkan drivers ?


#26

I guess it’s still the same error as I get. You just installed winetricks nocrashdialog in your WINE bottle (which is in the Lutris installer), which - surprise, surprise - doesn’t show these nasty error messages anymore. I did it to mine and now I have the same behaviour as you got

@cxf do you have an idea on what we could investigate? You seem to be the guru for BF4 for now :slight_smile:


#27

I can’t. I don’t own that game.


#28

Oh. Still my man!


#29

#30

Did anyone get BF4 running?


#31

Yes, BF4 runs wonderful for now. On running, just wait a fucking long time, I guess the first time it runs, it does some stuff in the background. It seems like it didn’t run BF4, but it just needs some time.

Use a virtual desktop, because Origin spams a thousand of windows, which (at least mine) window manager doesn’t want to process.

Also be sure if you use higher DXVK versions, it needs a newer nvidia driver version, which might not be in your repository


#32

I am stuck at origin complaining about dxgi.dll and d3d11.dll missing, what am I supposed to do with them, I tried changing config of wine and making them both native and the other option, it still complains about it. Also when origin launches battlelog website, the ping times dont show up, the servers are listed though…


#33

They have to be located in C:/Windows/system32/, so either put them there manually or use Lutris’ DXVK option (properties of a game, there you find it)

Be aware, as said, that if you use higher DXVK versions, it needs a newer nvidia driver version, which might not be in your repository (you can check the needed driver version on the DXVK’s GitHub page)


#35

Also got it to work now. Now I just have some issues with my mouse because it is really choppy in game and skips around. I know this is commonly connected to the virtual desktop resolution but how do you set the resolution correctly? Already set the virtual desktop in winecfg to 1920x1080 and in Lutris too (in the battlefield runner options). I unchecked “Windowed (virtual desktop)” as that gives me an error when I try to tab into the game.


#36

Hi did you download extra dlls to run bf4 or did it work without?

Also do you run as x86 or 64 bit executables ?

I have so many questions…


#37

Disable lutris ingame and gameoverlay in origin to seee if the mouse works better . We just installed the bf 4 lutris run . Now i have a problem to get iy to run with my nvidia card . No problem with amd and mesa git. Next time im gonna buy a better amd card