Back to the main site

Battlefield 4 Punk Buster kicks me

When i join a multiplayer game I can play for 3 seconds then I get kicked by punk buster and I return to the game menu.
Plz help.
PS I tried on Arch and Manjaro same thing happens.

Run pbsvc.exe in wine.

Pbsvc.exe is located in the Battlefield 4 directory.

I came here because I was having the same issue. What are we supposed to run pbsvc.exe for? I tried using it to reinstall punkbuster but that didn’t help. I also ran tests before and after getting kicked from a server, and they always complete successfully as if everything was fine.

Same thing with me… Follows

Has anyone figured out this one yet? Could it be a regression in wine?

I’m not sure exactly how, but I fixed this. Thought I’d post about it for other people having the same issue. I deleted the contents of the ‘pb’ folder within the Battlefield 4 folder, then downloaded the Windows version of PunkBuster from their website and used Lutris’ “Run EXE inside wine prefix” option to install punkbuster for BF4 from the standalone punkbuster app. It will probably take a couple tries, as it tends to throw timeout errors. Then I ran pbsvc.exe again, and all the tests passed. I was afraid it was not going to work regardless of that, like before, but to my surprise it did. No more kicks.

3 Likes

@Rakanoza Do you have a ping value in-game on the scoreboard next to your name? Some admins kick you if you don’t have a ping value (mine is just a dash).

I tried your fix, and I don’t get kicked by punkbuster anymore, but now by the admin…

You install the game, you install pbsvc.exe (NOT pbsetup, you need the service one). Worked without any issues here.

@chillyshackk if I try your solution, I get kicked by punkbuster, if I try @Rakanoza’s, I get kicked by the admin. In both cases I have no ping in-game, and the same ping in every server in the server browser.

Do you need the pb/ folder in the game’s directory?

EDIT: also when I install pbsvc.exe, all tests pass no problem. The problem is only in the game.

Not sure what you have done differently, works fine here just by installing pbsvc. And just in case: Did you try different servers? Official and unofficial ones?

Also: maybe try to install it from the windowed/virtual desktop view. In the configure window for your game check windowed/virtual > Save > start origin > you should have a start button at the bottom left like windows then from there: control panel > add/remove programs. Maybe it makes a difference, maybe not. Worth a try I guess…!

I tried what you suggested but I still have the same problem.

I have a couple of questions:

  1. Do you see a real ping next to servers in the server browser? All pings are the same on my end.
  2. Do you see your own ping in-game?
  3. Do you have a pb/ folder in your game directory?

Thanks.

I’ll check again for the ping I don’t remember for bf4, I did not have server ping in bad company 2 so I’ll try to check tonight. I do have a pb folder so pbsv path is Battlefield 4/__Installer/punkbuster/redist/pbsvc.exe

You can also try downloading pbsvc from the official website and replace the one in that folder with the one downloaded: http://evenbalance.com/downloads.php

If all of that fails then I am out of ideas, turn on all possible logs and see if you can find anything, not sure if anything pb related is logged into lutris, maybe your issue is not related to lutris or wine, google for punkbuster issues with bf4 and see if you can find a fix.

I just noticed I installed my game on a NTFS partition, and my origin installation on a ext4 partition. I’m going to install everything on the same ext4 partition and see how that goes.

Yeah it might cause some issues, mine is installed on a ssd, ext4.

@zjeffer you might also want to make sure all games and the programs that are needed to run are on the same disk.

Okay so I reinstalled everything on one ext4 partition.

Still doesn’t work. In a few weeks I’m going to replace my laptop’s HDD for an SSD, maybe it will magically work then.

What distro are you on? Which windows version are you set to in winecfg? Wine version / dxvk version? I’ll test what I can and see what makes a difference.

Arch linux 5.1.9
Wine version 4.9, 64bit, Windows version set to Windows 7 (I’m going to try Windows 10 and report what happens)
DXVK version 1.2.1 (but I noticed 1.2.2 came out today, will test again)

EDIT:
I tested with Windows 10 and version 1.2.2 of DXVK, nothing changed.
I also noticed the game folder wasn’t actually in the wine directories, but outside of it. So Origin still thought the game was on another drive while it was actually on the same partition. I fixed this but no changes.

Good news:

I found that if I install the Windows version of Punkbuster and install punkbuster for BF4 from the standalone pb app (pbsetup.exe), like @Rakanoza said, and also change my wine version to ‘tkg-protonified-3.21-x86-64’ instead of the latest version of wine (4.9), I have a ping in-game. In the server browser, I still get the same ping next to any server, but in-game it’s the correct value. So no more getting kicked with this wine version.

I did notice a slight performance drop with the older version of wine: every 1-5 seconds, I get a stutter that can last up to about a second. I didn’t get this with the latest version of wine.

EDIT: turns out the stuttering was because of thermal throttling. Fixed by lowering maximum CPU frequency.

If I use the latest version of wine + installing standalone punkbuster, I don’t get kicked by punkbuster anymore but a lot of server admins don’t like me having no ping value in-game, kicking me after a minute or two.

What wine version are you using?

Hi

I’m facing the same issue of punkbuster kicking me out of the game.

So I first installed “pbsvc.exe” but after it wasn’t working (no ping) I installed “pbsetup.exe” but unfortunately also this doesn’t seem to work as it should and again I got kicked out of the game after 10sec. (no ping).
I also changed the wine version to “tkg-protonified-3.21-x86-64” but still I have no ping in game :frowning:

OS: Ubuntu 18.04 bionic
Install path: Z:\media[USER]\Games\battlefield-1\drive_c\Program Files (x86)\Origin Games\Battlefield 4
Format: ext4
DXVK: v1.2.2

Would somebody know how I could solve this issue?

Thanks a lot!