Back to the main site

Battlefield 1 DXVK not running


#1

I installed Battlefield 1 (Trial Version) using the online installer (https://lutris.net/games/battlefield-1/) on my Asus ROG Strix GL702VM laptop running KDE Neon User Edition (16.04) and kernel 4.16.3-041603-generic. I followed all of the instructions on the website with the exception of “Make sure “Disable Lutris runtime” is unchecked in the game’s system options tab or else download will fail.” I didn’t have a download failure, plus this is an advanced option so I could not find it when I was installing the game. I have since gone back and disabled this, but the game still will not start.

Origin and the game both install fine, with only minor issues (download will pause temporarily at 22%). However, the game will not run. When I click the play button for the game, the launcher starts and the online status bar in the upper right corner changes from “Online” to “In Game Playing Battlefield 1 TM (Trial)”, but I am immediately dumped back to the Origin library. I checked the system activity in KDE immediately after hitting the play button, it shows that “bf1Trial.exe” starts, but then stops less than 2 seconds later. I think the exe is crashing.

What can I do to fix this?

Edit: I failed to mention that I have Battlefield 1 installed on my secondary hard drive in a NTFS partition. Origin is on my primary SSD. I also installed Zuma’s Revenge under Origin on my secondary hard drive and Zuma’s Revenge works fine.


#2

Ok, I feel like an idiot. I didn’t have Vulkan installed. I had it installed before, but I had to purge my Nvidia drivers for a new kernel install and forgot to re-install Vulkan after the purge. Vulkan is installed now, and the game launch window actually opens but now I’m getting a DirectX Error:

DirectX function “FindClosestMatchingMode” failed with DXGI_ERROR_NOT_FOUND (“When calling IDXGIObject::GetPrivateData, the GUID passed in is not recognized as one previously passed to
IDXGIObject::SetPrivateData or IDXGIObject::SetPrivateDataInterface. When calling IDXGIFactory::EnumAdapters or IDXGIAdapter::EnumOutputs, the enumerated ordinal is out of range.”). GPU: “GeForce GTX 1060”, Driver: Unknown

Any suggestions?


#3

Driver: Unknown

Seems like a bit of an issue. What DXVK are you using? What is your NVidia driver?

You said you don’t have problems installing things in a NTFS partition, but it ~could~ lead to trouble. Let’s think about this as a last resort, since you got another game running there.


#4

The NVidia Driver is version 396 from the default Ubuntu repository.

How do I figure out which version of DXVK I’m using?


#5

Right click battlefield 1> configure> runner options

It should be 0.63, according to the install script.

About “Disable Lutris runtime”, it’s alright, the script should take care of that as well. Funny you mention 396 is from the default ubuntu repository, because last time I checked it was from a non-default repository (community-driven).

Try

ls ~/.local/share/lutris/runtime/dxvk/

Do you have a 0.63 folder? If not, download it from DXVK releases, extract it there and rename it to 0.63, so it is the same name as your Runner settings should be: 0.63

My suspicion is that you don’t have a 0.63 folder. I’ve never automatically installed new DXVK versions from scripts, so I’m skeptical.


#6

I have the folder. It is version 0.63.


#7

I’m probably wrong on the 396 repository. I’ve messed with the drivers on my system so much, I forget where they come from. I do know that 396 is the recommended driver for my card. I had 390 installed, but got the same error so I installed 396 (and got the same error).


#8

At this point, I can only recommend checking the “appdb” page for the game and install scripts to get any clues of how are things working or not.

Then I’d try checking if every needed dependency is working by checking my “apt list” and running a given example with DXVK.

Does Zuma’s Revenge use DXVK? If not, do you have other games working on DXVK?

If they do, I’d check Battlefield 1’s wineprefix to see if something is missing, but I hardly doubt it, since you used the Lutris install script.


#9

look at this!!


#10

Thanks, but everything is in Portuguese. I don’t understand what he is saying. Also, I don’t know how to install WINE with Esync or how to install any WINE version in Lutris.

Edit: I’m very frustrated! I’ve been working on this for two days. I thought the Lutris installer was supposed to “setup” everything for me.


#11

I’ll upload one video to do this today in portuguese, you don’t need to know portuguese to configure lutris, the software is the same, just follow the steps, or you can go to lutris on github you’ll find everything you need to run esync or dxvk.


#12

Thank you! Will the steps be clearly shown in the video?

Also, will the Lutris team please look at the installer for the game? There maybe some stuff missing.


#13

Hey, check the description of this video again, I left one link to a step by step tutorial, in Portuguese but you can just follow the steps, try subtitle maybe can help you too, I’m my cell phone now it’s horrible to get links


#14

Thanks! Unfortunately I followed your instructions and it did not work at all. The game would not even start with the Esync version of Wine (esync-3.13).


#15

I’m new to the forums, so it will only let me post 1 picture for post (or is it thread)? Here is the error I am getting:


#16

Here is a picture of my winecfg setup:


#17

Here are all of the setup images on Imgur:


#18

Turn off Origin’s overlay “Origin In Game”


#19

Origin in Game is already off.


#20

Use a bigger virtual desktop?