Back to the main site

Battle.net Launcher crashes after login

First off, I have looked at the other threads and they haven’t helped. Anyways, first time I installed and launched overwatch (That’s where the battle net install came from) it worked fine. Exited the game and lutris, upon relauch it started crashing after login. Reinstalled Overwatch and the problem still persists. Here’s the debug log

https://pastebin.com/raw/6M8WPuqU

Here’s a newer debug that for some reason has some new errors in it

https://paste.ubuntu.com/p/nHfFWqvHGT/

Hi! It’s too bad you’re having trouble! I had the same problem with World of Warcraft and finally solved it this morning looking at this thread: [Solved] I was able to play World of Warcraft, but only once (Battle.net not launching)

The issue is that, by default, Ubuntu (I’m assuming you’re on Ubuntu by your pastebin link) uses stable but older versions of Vulkan and you need to add the repository that accesses the newest builds. I think mine ended up being up-to-date but missing a newer library.

The tl;dr is: go to this link: https://linuxconfig.org/install-and-test-vulkan-on-linux and follow the instructions for appropriate for your system and hardware. I hope this helps!

turn of enable DXVK in configure