Back to the main site

ZDoom games not using paths from game configuration

I’ve been playing various ZDoom games for the last while and they were working fine. It seems that with the latest Lutris update, the games no longer work properly.

It seems like the GZdoom runner is looking for the game’s files in the default gzdoom directories instead of where the game was installed using Lutris.

For example, I was playing Hexen https://lutris.net/games/hexen-beyond-heretic/ using the Neural texture pack mod version. Using Lutris 0.5.8, the game worked fine. The hexen.wad file is in the /Lutris/hexen-beyond-heretic folder that was created with the installer. The mod, saves and soundfonts were in the appropriate subfolders.

With Lutris 0.5.9, I’m given a fatal error:

Cannot find a game IWAD (doom.wad, doom2.wad, heretic.wad, etc.). Did you install GZDoom properly? You can do either of the following:

  1. Place one or more of these wads in ~/.config/gzdoom.
  2. Edit your ~/.config/gzdoom/gzdoom.ini and add the directories of you iwads to the list beneath [iWADSearch.Directories]

The game will work if I move the wad file to the ~/.config/gzdoom folder, as suggested, but these does not seem proper. Under the ‘Game Options’ in the ‘Configure’ menu for Hexen, there are paths to the WAD file, PWAD files, save path, etc.

It seems like with the latest update, ZDoom is not respecting the settings in the game configuration.

I have the same issue with all my installed ZDoom games.

Anybody else noticing this issue?

1 Like

After playing around with things a bit, I think what’s happening for me is that the runner no longer respects the settings in the ‘Game options’ for ZDoom games.

This means that the WAD file and any PWADs are not being read from the game’s installation location with Lutris. Instead it is looking directly in the ~/.config/gzdoom folder. This results in none of my ZDoom games launching. As a test, I dropped in my hexen.wad file into ~/.config/gzdoom and now every one of my ZDoom games will launch Hexen.

This also results in the runner looking for any savegame folder in the wrong location, and same with the soundfonts.

It does seem that the ‘Runner Options’ setting for the game works, since it picks up the gzdoom.ini file properly. So with only the hexen.wad file in the ~/.config/gzdoom folder, when I start Doom through Lutris, it will run Hexen but with my gzdoom.ini setup from Doom.