Xbox one d-pad gets mismapped using wine for subnautica /w epic games

I tried the settings i could find in the configurator. x360ce Dinput 8 mode, x360ce xinput 9.1.0 mode, Use dumb Xinput emulator, SDL2 gamepad mapping. when i look at the wine control panel, controller configuration. and all buttons and axisses are mapped there correctly. the d-pad is mapped to POV and recognized as a joystick field. it has 8 directions which all register. i have no idea how to fix this in subnautica since i don’t really understand where the fault lies. i run subnautica via the epic games launcher. and the xbox one controller wirelessly via the usb adapter. anyone have a clue? I am NOT using xboxdrv, i use xow.

This could be a bug in Unity, Firewatch does the same thing.

The fix I used was set SC-Controller to use the keyboard equivalents for the d-pad. So the profile used both controller and keyboard inputs

looks like the game has issues with controller mapping on mac and windows as well.

i also tried installing xow in xbox 360 compatability mode but the issue persists.

sounds like messy remapping is the only current solution on any platform