Xbox One Controller in Wine-GE

I’m trying to play the Division 2, which is an Ubisoft Connect game, using my wired xbox one controller.

The default Lutris installer for Ubisoft Connect uses Wine-ge-lol-8-27-x86_64, which does not seem to recognize my controller. When I go to the game controllers in the Wine Control Panel, my controller button presses are recognized in the dinput tab but not the xinput tab.

I tried installing the game via Steam using Proton Experimental, and while Proton Experimental recognizes my controller, it seems to have an issue loading the game because of Easy Anti-Cheat. I tried installing the Proton EasyAntiCheat Runtime but still can’t load the game in Steam/Proton Experimental. This seems like a dead end.

So now i’m going back the other way, and looking for advice on how I might be able to get Wine-GE to recognize my controller? Anyone have any success with getting their controller working in Wine-GE. I’ve been banging my head against my desk with this for two days because I don’t want to fork out $30 to buy The Division 2 again via Steam :rofl: :sob:

I ended up getting it working through steam with the instructions here, although the framerate is trash, game is somewhat playable.

Still, if anyone has any tips for getting a game controller to run on Wine-GE, i’m all ears

Note the lol Wine GE version stands for League of Legends only. Do not use it with anything else:

Per Thomas:

Occasionally, I also release League of Legends builds – These builds will specifically have ‘lol’ or ‘LoL’ in the name. Please note these ‘LoL’ builds are for specific use with League of Legends, and NO other games.