Back to the main site

Xbox 360 controller in World of Warcraft not working

Hi,

I am running lutris 0.5.8.3-2 on manjaro.
I am trying to play World of Warcraft with a xbox 360 controller.
In game it just does not register anything from the controller.

In Overwatch the controller works, and in Steam games also.
So, this does seem to be a problem related to WoW only.
I also tried the ingame console commands to activate the gamepad, and also tried it with consoleport. No change.

Also tried different input opptions in the runner (x360ce, xinput, etc), no change.

Has anyone a idea how to troubleshoot this/can give me some direction as to where to go next?
Or has anyone got it to run?

Thanks in advance!

Hey,
I am running lutris lutris-0.5.8.3 on ubuntu 20.04 lts.
I am trying to achieve the same, got my xbox 360 wireless controller working with xboxdrv, but it does not seem to be passed through into lutris so that I can play with it. I have not tried any other games.

Would love to find a solution for this, as I am trying to play on my laptop where I only have a mousepad. Note that I am trying to play the classic tbc client.

Hope this receives some attention and thanks!