Back to the main site

X Error of failed request: GLXBadFBConfig

I tried to install the world of warcraft via lutris and gave this error, I already searched on google for the problem but I didn’t understand very well how should I proceed, any ideas?

Nobody will answer if you don’t give any information. Check your graphic setup with glxinfo. Check vulkan capability of your deviceand whether it’s installed correctly.

I would like to piggy back on this issue. Here is my log when trying to play Guild Wars 2:

Running /home/akmar153/.local/share/lutris/runners/wine/lutris-6.0-x86_64/bin/wine /home/akmar153/Guild Wars 2/Gw2-64.exe -mapLoadinfo
Initial process has started with pid 3184
Start monitoring process.
esync: up and running.
X Error of failed request: GLXBadFBConfig
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 0 ()
Serial number of failed request: 228
Current serial number in output stream: 228
Monitored process exited.
Initial process has exited (return code: 256)
All monitored processes have exited.
Exit with returncode 256

This happened right after I updated the mesa-vulkan-drivers from 20.3.4~kisak2~f to 21.0.0~kisak1~f.

Anyone can help with this particular issue I am facing?

1 Like