X Error of failed request: BadMatch (invalid parameter attributes)

I’ve googled the error.
I’ve read the “Please read before asking for help” thread.
I’ve looked on the lutris wiki for solutions.
I’ve followed the instructions at: https://lutris.net/downloads/
I’ve followed the instructions at: https://github.com/lutris/lutris/wiki/Installing-drivers
I’ve successfully installed lutris on 5 different machines. They all have the exact same error behavior.
What’s different between the machines? Versions of linux and video cards. Some 2D, some 3D. Radeon/AMD, Nvidia, Intel. Some desktops, some laptops.
What’s the same between the machine? They all produce the exact same error when trying to launch any lutris game via the Dolphin runner:

X Error of failed request: BadMatch (invalid parameter attributes)

And it fails consistently, across all 5 machines, at the exact same spot. I’ve tried this in a LiveCD version of linux as well, and the error is exactly the same. I’ve tried rebooting after installing vulkan support. No change. I’ve tried toggling all the recommended toggles in the profile of the game (disable runtime, system libraries , fullscreen, desktop effects, run in terminal, all of them, each, together, none of those toggles change the error.

I’ve tried everything I can find in any support thread for related or unrelated products. I’ve tried changing the desktop resolution with xrandr. I’ve tried different versions of the various video drivers. I’ve tried blacklisting modules to ensure they’re not loading. Nothing. Every change I’ve tried and every troubleshooting step I’ve tried does absolutely nothing to remove this error. It is 100% consistent.


Just to make sure: your troubleshooting did involve running stuff like glxgears -info and vulkaninfo, right?
This error usually happened to me when NVidia drivers refused to work.
But if your videocard works correctly, the problem is likely with the current Dolphin version. In that case, maybe installing a systemwide version would work? (You may need to add some overlay to your package manager, I guess.) Worst case, you could try to build it from sources, they have a thorough instruction on how to do that.

Yes, those tools (and similar) work as expected, without error. All of these 5 PC’s involved are capable of playing and do play 2D and 3D native linux, wine and similar games, and have done so perfectly in a variety of roles over the past 3 years. The only thing that doesn’t work is lutris.

A bit of a thread necro here, but I had recently run into this issue myself. I found a fix for NVIDIA users and OpenGL games.

  1. Check that you have the required libs installed. lib32-mesa-libgl, lib32-nvidia-libgl, mesa-libgl, nvidia-libgl (if NVIDIA, I am).
  2. Go to the game that refuses to run in via Lutris and right click on it, select ‘Configure’.
  3. Turn “Enable NVIDIA Prime Render Offload” off.

That should be it!

1 Like