WoWS Crashes while Logging In

Greetings all, the Title Says it all. the game installed and will load just fine, but as soon as the Splash screen displays “Logging in” at the Bottom, the Game will stop responding, oddly enough the Music keeps playing. on top of that, I get the Following error in a pop-up window: dxdiag [/whql:off | whql:on][/t filename | /x filename]
I’m a bit new to gaming on Linux. Only been using it For gaming for about a Year.
In Short I’m trying to get World of Warships to work on the Wargaming App. I started Playing WoWS before it was released on Steam, so installing Via Steam is out of the Question. To that End I’ve been trying to get it to work Via Lutris/Wine, to no avail. I’ve tried Installing the Gamecenter in my Home Folder as well as on a seperate SSD. in either case Installation went through with zero problems

I used this tutorial right here:

Updated all of my drivers/dependencies as per this page:

On top of the Above, i updated wine and checked my Video card Compatability with the appropriate pages, visible from the above link
Lastly I searched within lutris for the Link to install the Wargaming Game Center.

from everything I’ve read over the Past several Months, this setup should work, but no dice. my system specs are as follows:
Supermicro X10-Dai Motherboard
Intel Xeon E5-2690V3 CPU
AMD RX480 Video Card (8GB version)
256GB SSD for OS
1TB SSD for Games
Ubuntu 23.04 Lunar Lobster

Did you figure anything out? Im having the exact same problem right now (also new on Linux).
I launch the Game Center, hit play.
The game starts loading data, after that it tries to log in, it freezes with music still playing.

Negative, I have not solved it yet. however I have discovered a few things that may prove Useful:
1- World of Warplanes Works with zero trouble.
1.5- Hearts of Iron 4 (HOI4) also works perfectly with Mods and all sorts of fanciness
2- DaVinci Resolve Doesn’t work at all, it can’t seem to find the Graphics card (AMD RX 480) In addition, None of my other games will work. Steam/Proton won’t get them to work, and neither will Lutris
2.5- Handbrake, and VLC will play and decode Video all day long, so i suspect that Davinci and WoWS/ Steam/Lutris Games need something that isn’t being provided. again, not sure what.
3- When i get a few Bucks ahead, I’m going to Buy an Nvidia Titan XP. It’s old enough that Drivers should be easy to find and install, but powerful enough to deliver Decent Performance, so I expect to have better luck with that.
4- After I accomplish all of the Above, I’ll post my Findings here.
5- if anything Changes and causes things to suddenly work, I’ll also Post my Findings here.

GREETING!!!, I have Finally Figured it out. Good News is Warships now works, Bad news is i had to do a few things differently than in the “How to” link I posted above, oh and I had to reformat my OS Drive and perform a Clean installation of Ubuntu 23.10. In short, i followed the “How to” link above, in the order that it said to do things, but i didn’t use Any of the Links posted within said “How to”. So when the above Link says to Install Wine or Lutris, i did those Independently, without following the Links Provided.

Here are the Steps i Followed:

In addition to the Above, I’ve also gotten Sins of a Solar Empire:Rebellion and Mech Warrior 5 (Via Steam/proton) to work with very little trouble. with that in mind, I think that there was Something Funky with my 23.04 Installation, which is why I strongly suggest you reformat and do a clean installation of Ubuntu. when I Installed Wine, I designated a separate Drive as my “C” Drive, so make sure that wherever you put “C” drive, that you also install all of your Windows games there. if you have any further Questions, feel free to reply here or Message me on here.