Back to the main site

WoW Wrong keyboard layout

Hello, I installed WoW on Lutris and everything works fine including the keyboard layout, except for the shortcuts. I use a AZERTY keyboard and when I type in the chat for instance, my keys are good but all the shortcut (even system ones like Ctrl+A) in the game are mapped in QWERTY (the layout is Bnet is good though).
I am using Arch Linux and all my locales are set to en_US.UTF-8. But vconsole.conf contains KEYMAP=fr-latin1.
I can rebind all the ingame controls and play for now, but I do not know how to do with the system shortcuts…
Does anyone know how to fix it?

Anyone?

are you french? why your locales are set to en_US.UTF-8 and vconsole.conf contains KEYMAP=fr-latin1?

Yes, I am french. I set my locales to EN because I can not stand french on a computer. vconsole is because I have an AZERTY keyboard. I would like to change but everyone here has one, so it is complicated… And from what understand from https://wiki.archlinux.org/index.php/installation_guide#Localization, vconsole is the file to change for the keyboard layout, but I use KDE which does modify it too. I set it to french too, but this could be part of the problem.
I tried Hearthstone too, same problem, but not with Steam games.

I did more tests and actually, Steam has the same problem if I use Proton. So I tried to reinstall Arch on a another PC with all the locales set to french, and this time, the keyboard is good. So it is a locale problem, but I don’t understand how to change Wine’s locale to get it to work on my main install… Can somebody help me, please?

I finally found by myself, so if anyone has the problem:
Check the setxkbmap -v output.
I had :

Trying Preformatted textto build keymap using the following components:
keycodes: evdev+aliases(qwerty)
types: complete
compat: complete
symbols: pc+us+inet(evdev)
geometry: pc(pc86)

To set it right : setxkbmap fr (replace fr with your country code)

In Arch I run this on startup (US International layout)

setxkbmap --variant intl

But I also face the issue of the keyboard sometimes resetting to default US layout when launching lutris. Running setxkbmap again fixes it (for a while at least?)

Mostly notice this in WoW because of typing in chat.