Wow - Wrath of the Lich King

Once I moved to Manjaro from Windows a year ago I used Lutris to play my favourite game, Wow, but the older WOTLK patch. Everythng worked perfectly in Lutris, for months without problems. But lately it started to freeze ingame sometimes. The game just freezes and only thing I can do is ALT-TAB to Desktop and close and reopen game.

This problem started after updates, both on lutris and wine. I mean I did several Manjaro updates and I remember playing WOW on Wine 5 and now it is on version 7. So I am not sure what causes issue.

Can somebody please just tell me which runner options to use in configuration. There are DXVK, VKD3D, ESYNC, FSYNC… etc… I tried several and same happends, but I didn’t tried it all.

As you know it is DX9 game.

Im running Manjaro KDE, Ryzen 7 2700X, 32GB RAM, NVIDIA GTX 1070 and 5.16 kernel. Wine is 7.4

It is really important for me this game not to freeze since it is online multiplayer game and stability is a key. My mates don’t have patience to do encounters with someone who constantly disconnects. Having it been a single player game, I wouldn’t mind freezing, I would just reopen game. Please help me I don’t want to go back to Windows because it is so ugly, so lagish and so terrible OS. Thanks.

1 Like

are you using opengl or DX for video?

There is no ingame options to check wether is DX or OpenGL. Also in config file there is nothing about that, so it should be DX, by default.

in the arguments in lutris put --opengl and see how it runs.

you can always use mangohud to show what it uses. i use VKD3D to run the game with GE-Proton7-7.

Well I did backup of WTF (without config) and addons folder and did fresh download and reinstall. For now everything is OK.

Kibasnowpaw, isnt VKD3D for dx12 games?

1 Like

yes and no you can force it in VKD3D and some games runs better. i would recommend to use the Cash command
DXVK_STATE_CACHE_PATH=/some/directory and DXVK_STATE_CACHE=1 willc cache the data so it runs better the more you play.