Back to the main site

WoW - Works in Wine, crashes in Lutris

Hi
At some point the last month something broke World of Warcraft in Lutris. I am not sure if it was an update of wow or Lutris. Either way i have tried so much stuff that i am not sure what was default anymore to get it working.

Issue:
When i am trying to launch World of Warcraft through the new Battle.net launcher, through Lutris nothing happens. Then after aprox 10 seconds of waiting, i get an error message and error report interface.

Error message:
Screenshot_20210325_141509

After trying everything me and my brother could think of, i tried just launching it directly through wine, and it works just perfect there, and it also works perfect from Windows. It is and has always been on a NTFS partition.

lutris -d gives me:


Note: There was no events when i pressed “Play” in the Battle.net launcher, and no events when the error popped up.

lutris --submit-issue gives me:

Also, GG for asking for logs and pastebins, but then limit new users link posting xD

Check your Wine Config in Lutris to see if it has reverted to Windows 7. I had this issue with Lutris and changing to Windows 10 fixed it. For me, it was DirectX 12 in the game being incompatible with Win 7.

2 Likes

How do i do this in Lutris? I had to do it in Wine to get it to launch properly when using just Wine. Not sure if that setting is global of if Lutris as its own stuff?

Screenshot from 2021-03-26 08-33-53

Thanks!
Sorry for the late reply. Its running Windows 10, same as Wine alone does.

If you change the executable in Lutris to point to WoW.exe, does it run?

It does not run when pointing Lutris directly to the game .exe

Tho its not inside the battle.net “windows” file system, i got all of them on a separate disk and install only battle.net using Lutris. Makes it easy to dual boot for patch days :slight_smile:

I was reading up on this issue, and someone suggested it was a file permissions error with the ntfs partition. They solved it by moving to a non-ntfs drive. I don’t know if this is relevant to your issue because you mentioned you can start the WoW.exe and BattleNet through Wine, just not through Lutris.

Yeah, it works perfect through Wine directly. Also tried copying the game from the NTFS drive to my home drive and it did not change anything.

Thanks for the help tho:) at this point i am probably going to do a clean install when the next update hits and reinstall Lutris/battle.net to see how that works.

1 Like

I have a second nvme drive where I run 5.12 RC kernel on Ubuntu 21.04 daily builds which shares my “production” WoW instance (on the other nvme drive). Win 10 on an SSD. Never been able to get the 3 “instances” to share the one Battle Net directory. Be very interested if the reinstall works - can you share the setup if it does work?