Back to the main site

WoW VoiceError:17

Hi,

ever since the Dragonflight prepatch arrived I have this error message:
"Lost connection to the voice chat service.(VoiceError: 17)"
The game is otherwise perfectly playable but this error message repeats every 30sec and causes a huge framerate drop that really makes it unfun to play. There is no error log created in the Errors folder.
Has anyone else encountered this issue and might point me to a solution ?

thanks in advance

Use Winetricks to see if you have sapi added to your Battle.net prefix

thanks for your quick reply!
Under Wine configuration it is set to sapi(native, builtin)

Go to winetricks->Select Default wineprefix->Install a Windows DLL or component->SAPI

Is this checked as being installed? If it isn’t, check it to install

Yes sapi MS Speech API is installed

iIt’s so sad… that is the only thing i still need windows for but can’t get it solved.

In your settings in game, options->System->Audio - what is your Output Device set to? Also, are you behind a firewall? SAPI.DLL ideally should be native only in the Wine Configuration

Ok I have set it to native now but it doesn’t seem to make a difference. Output device is set so System Defaut. Only the built in one of endeavouros. On the same device in windows i don’t have any issues.
Thank you for your time really appreciate it!

One thing i have also noticed is that it takes forever to get to the character selection and sometimes fails to connect at all which will leave me with the reconnect screen where once i click on reconnect i get instantly connected

If you disable sound in WoW, do you get the same error?

yes

Long shot - use the Overwatch 2 installer to install a clean battle.net in a prefix and after installation is complete, add sapi.dll and then login and use locate game to find your current install of WoW

sadly that also doesn’t work. i will try an older kernel tomorrow

Also check if you have a firewall somewhere - either router or on linux - blocking the ports used by that service

1 Like

Recently switched to EndevourOS (i3wm) and started getting this error as well as an extremely long login screen. Didn’t have this issue on manjaro/kde.

@Slothpal it’s the firewalld service that ships with EndevourOS causing the error.

1 Like

Ok thank you for your reply have you figured out what permission was missing ?

Ok yeah it definitely is a firewall related issue. After stopping the service temporary everything works. Instant log in, no VoiceError17.

allow port 3724/udp in firewalld then do systemctl restart firewalld

1 Like

Thanks a lot!