WoW on Manjaro 18.0

Hi, how are you?
I’m trying to play WoW on Lutris 0.4.23. tgk-3.19, DXVK 0.91
The installation in Lutris only worked when I left the path unchanged.
When I try to run WoW it closes, it follows Lutris -d with Launcher.exe -
PS: the login page appears and closes.

With Battle.ner.exe -
PS: opens, but the game does not.

Is it possible that the launcher passes the login details to the WoW.exe?
I ask because I have not played the game for years and do not know what changes there were.
I just want to say that there are games that in order to DRM the login only about the launcher, and then create a token and passed to the game with the start command.
But what I would test for a look at your log files would be the current esync staging version and if your video card supports vulkan at all

1 Like

Try setting it to windowed mode. WTF/ -> SET gxWindow = “1”

I’m running WoW in Manjaro just fine. I’m using tkg-nopulse-3.19 and DXVK 0.91. I also check “Disable Lutris Runtime” and “Prefer system libraries”

You want to use the launcher.

1 Like

I check “Disable Lutris Runtime” and “Prefer system libraries”, use tkg-nopulse with dxvk 0.91, but no results, Launcher close after seconds.

secon i have a gtx 1070… i try with esync, without, the game not work. :frowning:

Oh the launcher closes? Did you install the dependencies?

1 Like

Everything installed correctly. Including the vulkan libs.

How is it going?
Have you tried using the Wow.exe executable directly?
I personally do not use the Battle net directly- I use the “World of Warcraft Launcher.exe” in the game install directory to open that up, or preferably, the Wow.exe opens it up for game patches, which is about the only time it is needed by me. Otherwise the Wow.exe is all that I need to launch the game either from Lutris or on the command line with the Lutris runners.

Of course if you need the Battle net desktop app to still install WoW, you will need to clear that part of it first or install from Windows and then run it with wine as I did.

1 Like

I did, just change the launcher to and change the option to close B.N when the game starts. Many thanks to all who helped. :slight_smile: