WoW Keyboard Movement Issue

EDIT: I found the problem to be the GPU somehow. Turned down the graphics from 6 to 4 with a few tweaks on quality (from Fair to Good) and the issue is gone. Maybe the Liquorix Kernel is not working fine with my GPU while playing WoW. Got to test with the default Kernel first.

I’m back playing WoW retail on my Dell laptop, only now using Ubuntu 20.04 along with Liquorix Kernel and Wine Staging v5.19 (Gamemode and E-Sync are ON). I use a Bluetooth mouse and all my drivers are up to date.

I’ve installed the game a few weeks ago before the pre-Shadowlands patches and it was running smoothly with no issues at all. After two to three heavy patches since the last 13th, changing the game’s appearance including characters customization and all, I’ve started having this weird movement problem.

By using AWSD or arrow keys on my laptop keyboard, the character keeps running even after releasing the key and simply won’t stop for many seconds after. Meanwhile, ESC or jumping doesn’t work, or any other shortcuts to help stop it. Seems to be directly related to the mouse camera movement.

I’ve researched for a solution and came across some tweaks listed bellow but none worked for me:

  • Change Wine version: the only one working right now is Staging 5.19, preventing the game from crashing;
  • Repair and Full Re-installation: deleted folders and downloaded from Lutris, didn’t work
  • Rename WTF, Config and other folders;
  • Using in-game the command /script SetCVar(“rawMouseEnable”, 1);
  • Using the command /console RawMouseEnable 1 (also 0 value);
  • Enable Lock Cursor to Window in-game;
  • Turning on the option ‘Automatically capture the mouse in full-screen windows’ in Winecfg

I’ve tried running WoW with the app and directly from the .exe file - both using Lutris. Nothing.

This never happened before and my laptop keyboard is working just fine. Other games on Lutris via Wine are also working without problems.

Does anyone have any ideas? Maybe could be the Liquorix Kernel for some reason? Maybe a conflict between the new patches and Wine Staging 5.19?

Any help would be very much appreciated!

PS. I’ve noticed a folder on my /home/ directory called GPUCache that apparently was created by WoW. Unaware of it, I have deleted the folder. Now I notice some additional lag loading the character selection screen and when entering the world. Could this be related? Is there a way to recover it if it is necessary?

Depending on your directory structure I cannot imagine that WoW is able to create any files in your home directory … only the wine prefix is available to WoW. It doesn’t know about anything beyond that because it’s a Win program. So that GPUCache might be important but it was created by a Linux program.
I haven’t seen your issue but you can easily rule out Liquorix: Just boot into your system kernel and check. I’d suspect a graphics problem.

1 Like

In app go to Settings -> Game settings and choose to reset in-game options. Check in Wine configuration if OS is set to Windows 10.

1 Like

Have some caution configuring Wine outside of Lutris - it can nuke your install of the game by adding extra progs/different paths in your bottle and I have not found it necessary. Once done that way initially you may have to continue to adjust things externally - a clean install of the game after deleting the bottle completely and then not touching the auto-generated wine config or wine-tricks for that install can correct any issues introduced. WoW has always, and continues, to run better under Win 7 or XP - but whatever is set up initially under auto-install should be left.

That said, for interface lag or lock up try running under a diff MINIMAL window manager (I use Budgie, after trying several others) and disable desktop effects under sys config in Lutris. There is a definite conflict that introduces strange lag under Gnome or the new KDE WMs. Also, if you use alt-F4 to page out and in to the game window your inputs may get stuck.

1 Like

Hey, Kaimon. Thanks for your reply!

Yes, I couldn’t understand the home directory thing but it seem not to be a problem after all. And you’re totally right. I might have been some other software.

I can’t understand how it would be graphics. Everything is up to date and amd runs smoothly with WoW. I’m not having problem on any other games or softwares that require mid to heavy GPU usage. I don’t even have a clue on how to start an investigation about it.

About the Kernel, I might give a try although Liquorix is highly recommended for Linux gaming.

Hey Dwuimienny. Thanks for your reply!

I’ve already tried to repair and reset in-game options before. I will give it another try.

About the Wine configuration it is already set to Windows 10.

Hey Ubkma. Thanks for your reply!

Didn’t know about the Windows version matter. About configuring Wine outside Lutris, I never do that. I might change de runner inside Lutris but otherwise, I keep the default configuration always.

To disable desktop effects in Lutris is a great idea! I will definitely try that.

Budgie as far as I know is a distro that uses Ubuntu as its core and GNOME as its Desktop Environment. Only lighter and simpler. I do understand your point but I really doubt that this is an issue with Ubuntu itself or even GNOME, although I’ve heard complaints about GNOME and performance issues before. My experience with Ubuntu is being good so far.

Anyway, I might try to rollback to the original Kernel before thinking about changing the Distro and DE.


Guess you were right, mate. It is indeed a GPU issue. Turned down the graphics from 6 to 4 and it worked. Maybe the new Kernel has something to do with this. I will do some tests.

Thanks again!

Hmm, try this: in your config WTF file look for SET gxApi line and change it to SET gxApi “GLL” when Lutris and game is closed. Then test if on level 6 graphics issue still persist. My latency and framerate stabilise when I use GLL.

Hey, Dwuimienny

Went to the WoW directory and altered the WTF.config but it didn’t help. In fact, it got a little bit more messy in-game. After logging out from the game and from Lutris and checking the .config file again, the SET gxApi line went back to its original value ‘‘D3D12’’ automatically.

Anyway, thanks for the tip!

okay, i fixed it.

open ‘Universal Access’ settings and disable ‘Typing’ → ‘Repeat Keys’

1 Like