WoW freeze in character selection screen

Hello! I am very new to lutris and would call me a noob :slight_smile:

I just installed PopOS, made all the upgrades and updates and tried to play World of Warcraft with Lutris.
First I installed WoW through that “Install” Button on the WoW Lutris website. It installed battlenet (first it downloaded some dependencies) and after that I logged in and installed World of Warcraft the same way how I would do it on a windows pc. The “freeze” problem occurred.

I removed WoW through the Lutris client and installed BattleNet (install button from the website again). After that I installed WoW in the launcher again: Same problem.

I checked if I have all the needed dependencies installed for battlenet and vulkan etc etc (it already was).

This forum tells me that I am only able to post two links as a new user… well … then here they are in a Pastebin … :):

Sometimes this window appears:

Help :slight_smile:

Try to update Wine to 5.21 then ask Lutris to use it for WOW


Worked! Thank you!

I have the same problem, I’ve seen in some places to install version 5.19 of wine and use DirectX 11, but I haven’t been able to do that yet. If you know the solution please post and guide me. Thank you very much in advance.

@morias You should use Wine 5.21 which is available in Lutris now.

1 Like

It worked! thank you very much for the tip, now I leave the windows instead, thanks for the attention, nobody had helped me so far !!!

1 Like

Odd, I have not been able to get the 5.21-staging version to work at all. I had to roll back to 5.20-staging to get back into the game.

Just to keep this updated, using lutris-5.21-2-x86_64 has worked great once it landed.

Since yesterday evening the Launcher doesn’t work anymore, do you guys have this problem too? The game itself runs when I change the executable to the game’s .exe though.

//Edit: okay there was a weird overlay in the launcher itself (the dark area), I just clicked at the most top of the darker area and it diappeared, the Play button etc. is back there again.

Just to keepr this updated, do not update to wine-staging 5.22. Keep something in between 5.19 and 5.21.
And sometimes Blizzard has these weird advertising overlays …do not panic but try to blindly find the x :slight_smile:

  1. Use lutris-wine 5.21

  2. launch WOW with dx11legacy option.

More details here: