WoW Classic WOTLK crashes on loading screen with error #132

I am on Ubuntu 20.04 with HD Graphics 620 Kaby Lake and I’m running Battle-Net and WoW Classic WOTLK in Lutris. When I first open Lutris → login to Battle-Net → open WoW → and select a character, everything works fine until I get to the loading screen. Then WoW crashes and gives me an error #132 and references the sapi.dll library. This will happen about 3 times in a row and then eventually I’ll successfully login and be able to play for many hours, but then next time I try to login I’ll get the same error 3 or 4 times.

I went through and double-checked that all of the drivers and wine dependencies are installed. Looking at other posts on this forum and elsewhere for the #132 issue, I saw some solutions, but they didn’t work for me. For example, I made sure my Battle-Net wine configuration was set to Windows 10 and I tried adding an override for the sapi.dll library. To get the game to work in the first place, I set the Graphics API to DirectX11 in the in-game menu.

In case it’s relevant, I have also twice had a sudden crash in the middle of playing, but it doesn’t look like WoW saved an error log for that. Haven’t been able to reproduce this second problem.

Here is the output of lutris -d when I recreate the error:

Here is the WoW error file when it crashes:


If it helps, here is my hardware information from Lutris:

99% that you are missing sapi.dll - Yep 100%

You will need to go to winetricks to add this dll. Not sure what you may need to try, but this link should get you through adding it

1 Like

I did a fresh install of BattleNet and WoW just to be sure and was still getting the error. Then I added sapi.dll and tested it several times and it seems to be working now. Thanks!

For anyone else who runs into this problem, here’s how you fix it:

Select Battle-Net in Lutris. Click the up arrow next to the wine glass at the bottom. Select Winetricks. Choose “Select the default wine prefix” and hit Ok. Choose “Install a Windows DLL or component” and hit Ok. Scroll down to sapi.dll, select it, and hit Ok. Wait for all of the installers to complete. Once you’re back to the menu “What would you like to do to this wine prefix?” hit Cancel. Donezo.

Wish there was someway to add it to the install script - Anyone know how to request an update to the script to include it???

I was wondering that too. It looks like it’s possible to submit edits to certain install scripts, for example the WoW Classic install script, but I used the battlenet installer and both that one and the main WoW installer don’t appear to allow edits.

@jhu I am still getting the random crashes in the middle of playing. It seems like WoW itself doesn’t crash, because it doesn’t generate an error report. Instead, my whole pc freezes and I can’t alt+tab or kill any processes. I just have to hard reset my computer, wait for it to boot up, and then do a normal reboot. Then WoW works fine again. Any idea what might be going on?

Check your system logs to see what is happening, it is possible that you may need to reduce the settings in WoW with Kaby Lake - I don’t currently have one to test. WoW hammers memory also, what ram do you have? Another option is to try a different runner like Wine-Staging.