Back to the main site

Wow Classic: terrible performance

Hi,

I used last weekend to play the stress test of the upcoming release of WoW Classic. Until sunday afternoon I played at 30 fps (never more, I don’t know why - is this an arbitrary limit?) at classic effects setting at 1920x1440 resolution. But out of nowhere the performance dropped to a constant 8. I set the effects to zero, the resolution to the bare minimum and disabled all addons - no change. Even the login and character menu screens are terrible.

My system:
i7-7700T @2.9 GHz x8
Intel HD Graphics 630 (KabyLake GT2)
16 GB RAM
Ubuntu 18.04
DXVK and Esync enabled (and yes, I set the 524288 limit)

Now, I have seen people play even BfA on more than minimum settings with the 630HD. Plus, the official minimum requirements set by Blizzard are also way lower than that. Imho, it’s not a hardware isuue. I’ve played Vanilla back in 2005 with better graphics on a machine that every household fridge laughs at nowadays. In theory I should hit 60 fps even on a bit more than minimal settings. I do not want high end visuals, I just want it playable - and 8 fps definitely is not.

As a side note, my system is getting considerably slower when I run the game (also when it was still running at 30 fps). And neither CPU nor RAM are close to their limits. Not one of the cpu cores hits 100%. And still, browsing in Firefox while windowed Classic in the background is a pain in the ass.

Unfortunately, the stress test is over and testing any suggestions will be limited to the performance of the login and character screens. But I will appreciate solutions nonetheless. As it stands, playing on August 27 is not possible for me.

lutris --submit-issue output:
https://paste.ubuntu.com/p/fdm5YbY9FG/

lutris -d output (starting the game, logging in to the world, walking around a little bit and exiting):
https://paste.ubuntu.com/p/xjrwhtTQ2s/

lutris -d log output (same procedure as above):
https://paste.ubuntu.com/p/JnqShfGKwQ/

Greetings and hoping for some help
Marcel

Interesting that you specify 8 FPS, as by default when foreground/background FPS limits are enabled it is set to 8. So I would double check that neither of those checkboxes are enabled in your settings. I would also suggest toggling them on and then back off to ensure the settings are correct.

Hi softea,

thanks for your response. First, the defaults for those settings are 100 in foreground and 30 in background. I had that thought too, since I couldn’t get higher than 30 fps initially. So I unchecked those boxes already and nothing changed. I have to admit that I didn’t try that after the drop to 8 fps but I highly doubt that that’s the cause, or otherwise it would have solved the 30 fps in the first place.

I read somewhere that it is recommended to make all the tweaks and settings that Lutris needs (e. g. DXVK and Esync) before installing Lutris and therefore any game. I did some of those settings afterwards. Could it help to uninstall WoW Classic and Lutris and start over?