Wow classic cant interact with an npc or chat

Hey, after fresh installation of the classic wow, suddenly my chat does not work or i cant interact with an npc. Also when i log out i cant see my characters, i have to restart the game instead. This seems like a networking issue.
Logs from lutris when i click show logs Started initial process 52477 from gamemoderun /home/joel/.local/share/lutris/ru -
Logs via lutris -d INFO 2023-04-21 13:34:25,079 [startup.init_lutris:237]:Starting Lutris 0.5.1 -

What to do?


Update this This application has encountered a critical error:ERROR #132 (0x85100084) Fa - is error logs produced via wow.exe.

Could this The instruction at "0x000000035e52b776" referenced memory at "0x000000035e52b776". The memory could not be "executed". explain the unwanted behavior of the game?

How did you install WOW Classic? You used a Lutris script installer? If so which one?

i used the battlenet script and installed wow via bnet.

1 Like

Ok, now i have tried several installers without any results. (diablo, wow, wow classic, startcarft, overwatch)

I am having the same issue since a couple of days ago. Played flawlessly for a month. I even distro hopped from Manjaro to PoP today in hopes of a fix but no luck.

The weird thing is that when I log in everything works fine for about 30 seconds. Every new player that appears after that shows their name as “Unknown”, chat does not work and I am unable to teleport because I get stuck in a loading screen and have to Alt+F4.


Hello Wacha, which Lutris script did you use to install WOW?

I don’t know if I can post a link here but I have used the one from Lutrisdotnet website “World of Warcraft (Classic)”

And in the last post I forgot to mention that since this problem the launcher keeps asking me to update the game on every launch and finds nothing to update every time.

Please use only this script to install
Blizzard - Lutris
and about " launcher keeps asking me to update the game on every launch" it’s a known bug, try another wine version, like 8.5 staging, if you know how to install it.

Thank you for trying to help. I had some time and did some experiments.

I have tried the script that you have provided with no luck. Tried 3 different wine versions witch I downloaded via Lutris’s “manage versions” interface with no luck as well. I even tried running the game on my mobile internet on a Wifi hotspot. Same issue persists, works fine for 30 seconds, then all new players that appear have their names as “unknown” and I cant type anything in the chat.

I would be willing to provide logs, but I would need some more information on how to do that as I am not very tech savy :slight_smile:

1 Like

Please verify and follow steps described in this docs:

yes my initial installation was via script. I just mentioned that i tried several installation scripts.

1 Like

drivers are ok and i dont have any issues with bnet.

1 Like