Wow Classic, battle net not launching after first time

Hi everyone,

After installing WoW classic using Lutris script yesterday everything worked flawlessly, but today I turned on my PC and now when i run it, nothing happens I can see the Bnet icon on my topbar (Pop OS) but bnet never opens.

If I run wow.exe works, but I wanna run bnet to install updates since WOLKT releases today.

Im runnning the latest Agent.8020 that has the bnet fixes and yesterday it worked just fine, now it just never opens.

Ran lutris -d and got thie error

[0926/] WSALookupServiceBegin failed with: 0
[0926/] DXVAVDA fatal error: could not LoadLibrary: msmpeg2vdec.dll: Module not found. (0x7E)
[0926/] DXVAVDA fatal error: could not LoadLibrary: msvproc.dll: Module not found. (0x7E)
wineserver crashed, please enable coredumps (ulimit -c unlimited) and restart.

1 Like

Disable esync and fsync when you need to use for updates, and keep them enabled, point to WoW.exe when you want to game.

Out of curiosity, what is the benefit of re-enabling esync and fsync? I’ve been leaving these disabled and just loading the game through bnet and that seems to work fine. Would framerates be better with them enabled?

Also, would you do this by going into Configure and changing the executable from bnet to wow?

Most people report improvements in framerate, on my system at 1440p, it greatly improves the 1% lows.

You can do that. Other people have different methods, even separate prefixes.

This seems to be working just fine thanks, sometimes when I login game crashes with ACCESS_VIOLATION error, but after a few tries I can play for hours

Check in your ProgramFiles (x86)/classic folder to see if there is an errors folder. Check the .txt folder for the error details, with WoW retail, missing sapi.dll is most likely cause.