Wotlk battlenet launcher stopped running (return 256)

I downloaded the prepatch a few weeks ago and played it just fine, but then about a week ago, the game froze, and it hasn’t let me open it since:

I see that there’s a well known issue that has been introduced recently, but my symptoms don’t seem to match

This is slightly different. Do not delete your Wine prefix - need to repair the launcher.
First thing is to go to your prefix and find the ProgramData/Battle.net folder and delete it.
Next locate the ProgramFiles (x86)/Battle.net folder and delete this.
Next navigate to the Blizzard site and download the Battle.net setup application.
In Lutris, select run exe in prefix and use the setup application you just downloaded.
Once you get to the login screen, login and use locate game to find your existing WoW install.
Exit the launcher and check that you can restart the launcher from Lutris.

Thanks for the advice. I tried this, and it did work except when I restarted lutris and tried to run battle net from within, I get this:


I reinstalled it again, and this time I actually played WoW, and now it persists :slight_smile: