Back to the main site

World of Warships

Recently Wargaming changed the way the installer for the game works, it needs a launcher app called “Wargaming Game Center”. So the installer scripts here on Lutris are all broken. Could someone write a new installer please?

There is already a lutris runner for that.

Since patch 0.9.6: sadly for me it either just freezes when the wargaming logo inside WoWs shows up (game center works fine). Or it completely crashes.

Tried all I could think of, so just a question is this working for someone? I am on Manjaro KDE.

Thanks!

Try running lutris through the terminal with the “lutris” command.

1 Like

Okay, now you really got me lost. Indeed it is working via cli and lutris command but why?? Is there a difference in gui and cli, there should not be but as it is now running there has to be one.

Summary:
lutris gui: stuck at wargaming logo when warships is starting
lunching via .desktop: stuck at wargaming logo
cli:Copied command from .desktop “lutris lutris:rungameid/22” -> Up and running…

Thanks for the tip! But would you mind explaining why cli is working and the other two don’t am I missing something obvious?

1 Like

I do not know why it works, but it does. : )

1 Like

What the ever loving hell!? It worked! Jeez, that needs to be looked at.

for me the game not working anymore.
If i start from Wargaming Center, a critical error has been occourd, Win10 prefix i think, the wargamig center runs with windows7 prefix.
if i start world of warships from lutris, it says the wargaming center is required.
from terminal the same error. it does not work. shit

This doesn’t work for me. I’ve installed the new “Wargaming Center”, but it just shows a black screen.

Where do you get the “rungameid” syntax from? I’m assuming the id is the game id listed in lutris --list-games.

I only have 1 game, and if I run `lutris lutris:rungameid/1", it does launch the Wargaming Center, but it still just shows a black window. However, it does briefly show a small “Wargaming” splash window, and it says it’s updating Wargaming and World of Warships, but the main window stays black and I can’t tell what’s going on, if anything.

If I enable DXVK, then the Wargaming Center window renders properly. I had it turned off because with that enabled, nothing worked.

However, if I then launch World of Warships, then that just renders a black screen and nothing happens and I see this in my terminal:

DXVK: No adapters found. Please check your device filter settings and Vulkan setup.

Well crap. If I keep DXVK disabled, but click on the region of the black Wargaming Center screen where the “Play” button is for World of Warships, then it launches and renders correctly and everything.

If Wargaming could do me a favor and stop changing their damn system very other week, that’d be greeeeat.

Hi,

I am totally newbie in Lutris, but Windows 10 “feautures” makes me to decide to move to Linux Mint 20. The only thing which is not working is WoWs. Steam is working, but no-go due to impossibility to use WG account, PlayOnLinux is not working… I have laptop with nVidia 960M.

When I tried (2 days ago)Lutris for the first time, game has crashed on Game center instalation error. Yesterday, I have tried to install Game center via Lutris first (Lutris set wine to Windows 7 automatically after Windows 10 error). It is working and it has installed the game successfully, but when I launch the game, I get error during game splash screeen (Wargaming logo). It does not matter if I am launching it via gui or command line. All setting are set to default.

Could you, please guide me, what to do? Thanks.

PS: I have one idea, which I should try…
Do you think, that copying of the game or game center files could help? For example to install game through Lutris, and then copy Game center files from working Game center virtual drive into that game virtual drive? Or vice-versa…

I will try to put together what I did to make World of Warships runnng via lutris. Maybe this can help someone figure out an/their issue. As I have myself not a really deep knowledge of lutris, I won‘t be able to help you much further if what I did is still not working for you.

So as in my previous post my issue was:

„Since patch 0.9.6: sadly for me it either just freezes when the wargaming logo inside WoWs shows up (game center works fine). Or it completely crashes.“

So first things first:

I installed the wargaming game center via lutris install script:


(For me: EU DXVK version)
This sets also wine to windows 7 and enables DXVK

Next step get the lutris run command gameid (lutris:rungameid/XX) either by lutris:
lutris --list-games

„22 | Wargaming Game Center | wargaming-game-center | wine | -„

or by creating a desktop shortcut and getting the id from the .desktop for me it was 22.

Check lutris is NOT running (when the lutris gui was open it does NOT work for me).

Now lunch via terminal by:

lutris lutris:rungameid/XX (for me: lutris lutris:rungameid/22)

I made a bash script so I can just place it on the desktop and click with content:

(Works on KDE and/or systems which have “konsole” installed, just so you get the idea)

#!/bin/bash
konsole -e lutris lutris:rungameid/22

P.S. my configuration for wargaming game center in lutris:

• Prefix architecture: 64-bit
• Wine version: lutris-5.7.5-x86_64
• DXVK version: 1.7L-3322-da4-2
• Enable Esync: on
• Disable desktop effects: on
• Reduce PulseAudio latency: on
• Enable ACO shader compiler: on
• Environment variables:
    ◦ DXVK_HUD 0
    ◦ MANGO_HUD 1

Hi and thank you!

I have reinstalled Game center including drivers, set most of settings according to yours (although mine wine version is 5.7.8) and then tried tu run from command line and it WORKS! :slight_smile:

But there are 2 problems:

Major:
FPS are only around 18-20 on Medium details. On Windows I had around 35 FPS on Medium details. I dont care details very much, but 18 FPS seems to be too low for comfortable playing.

Minor:
I have white stripe on right side of screen. The game does not recognize my 1920x1080 screen, it thinks in its settings, that there is 1912x1080 (in lutris settings there is properly set to 1920x1080). Maybe edit of some game *.xml file should help?

Thanks

Wasn’t able to make the method above work(was getting some vulkan/dxvk error and didn’t really found a way to fix it). However I figured another way to make WoWs work, might be helpful for some. So the thing is that the game itself seems to only work under win10, while game center installs and works under win7. And since you can’t just skip launcher the solution is to just manually add WoWs exe as another game in lutris with same settings and in same wine prefix where you installed game center, and then sey wine config to win10 global/win 7 for wgc.exe. After that you just launch WGC in lutris, wait for it to load and launch WoWs in lutris. FInally worked for me this way.

I had similar idea before, but I didn´t know how to add game in lutris into game center into same wine prefix… Could you, please, tell how to do this?

Thanks

Today i had a little update from wargaming center, can be older but i had it today.

  1. open terminal type lutris
  2. open in lutris the wargaming center
  3. close lutris GUI
  4. open wows from wargaming center.

This is new, i can open the game from wargaming center and i think i can play. Had no time to test it longer, i am in homeoffice.

But if i open Lutris from menu or shortcut and made the same steps, the wargaming center opens but the game can not start.