Back to the main site

World of Warcraft: WoW51900319 error


#1

I’ve installed WoW and with a few tweaks got it to install.
However, when I start the client, I immediately get a WoW51900319 error, and also if I try to log in.

Running Lutris on Manjaro with a Nvidia 710M card (using Bumblebee/primusrun).


#2

I switched from Bumblebee to Primus to make sure I got as much performance out of my card as possible and simplify setup. Tinkered with settings for a few hours, still no luck.

To get to the core of the problem, I decided to go the manual route and ended up with this script to make my life a little easier:

#!/bin/bash
gamedir="$HOME/GamesWine/WoW"
gamearch=“win64”
installer="$HOME/Downloads/World-of-Warcraft-Setup.exe"
launcher="${gamedir}/drive_c/Program Files (x86)/Battle.net/Battle.net Launcher.exe"
if [[ -f “${launcher}” ]]
then
WINEPREFIX="${gamedir}" WINEARCH="${gamearch}" “${launcher}”
else
if [[ ! -d “${gamedir}” ]]
then
mkdir -p “${gamedir}”
fi
echo “Configure Wine”
echo “Check https://linuxconfig.org/how-to-play-world-of-warcraft-on-linux-with-wine for required options.”
sleep 5
WINEPREFIX="${gamedir}" WINEARCH="${gamearch}" winecfg
WINEPREFIX="${gamedir}" WINEARCH="${gamearch}" winetricks corefonts
if [[ -e “${installer}” ]]
then
chmod +x “${installer}”
WINEPREFIX="${gamedir}" WINEARCH="${gamearch}" “${installer}”
exit 0
else
echo “World of Warcraft installer not found!”
exit 1
fi
fi

Using this after installing the wine-staging-nine from AUR I was able to log into the game without the WOW51900319 error. That suggests the error is caused by something in the Lutris settings. Where, however, I don’t know, but it would be nice to solve this.

My performance and graphics rendering using wine-staging-nine is not great, but since this is not an issue with Lutris, it is outside of the scope of this forum.


#3

Are you still facing any issue?


#4

I’m still using the shell script I am posting here. Haven’t tried the Lutris install since.
The script works fine (with minor in-game issues).