World of Warcraft input lag, current solution

Hey Gamers,

If you’re having input lag in World of Warcraft, chances are it’s because you’re using a version of WINE that has a bug for this. Until this is fixed, the solution I’ve found is switching your runner to lutris-4.16-x86_64. If you’re on any version higher than that, be it 4.17, or even 5.7, you will get annoying input lag on your keyboard inputs (character movement, etc).

I’ve reported this bug to the WINE devs, and if you have this issue, it would be appreciated if you posted your comments on how it impacts you in the relevant bug report, found here :

I’m hoping some day soon it gets fixed, so we can start using newer versions of WINE for World of Warcraft again, but until then, this is the solution I’ve found.

Hope it helps! :smiley:

1 Like

Some versions of GNOME will do this too (switching to another DE works). I am currently using 5.6 wine release and do not have any input lag!

I use a lot of Gnome Extensions, so switching to 4.16 works better for me. Plus, this issue looks really to be DE agnostic, based on the reports of others.

Yeah I was looking for a solution to my input lag issue, which was huge (basically it felt like my key-presses were queued and it would take a while for them to all play out).

Someone in the thread said to switch from GNOME to something else (I installed budgie really quickly) and sure enough, the problem went right away. Glad your root cause is different from mine!

Sorry for bumping this thread after such a long time, but it’s one of the results you can find while searching for this issue on the internet.

This issue is most likely caused by accessibility settings in your GNOME configuration. I’ve fixed the very same issue as described, by lowering “Speed” value in “key repeat” settings in Accessibility settings. Disabling key repeating works as well.

Yeah except many of us actually LIKE key repeating…