Back to the main site

World of Warcraft & EGPU = Low perofmrance

Hi there!

I am running a setting where I am using an eGPU (RX 580) box on a Yoga 920 (i7-8550u). In Windows 10 this nets me very decent performance, on medium settings easily surpassing 100 FPS.

Using Wine Staging 5.19 with the Lutris default install script and using the DRI_PRIME key with value 1 to enable the eGPU I don’t get anywhere near that performance. I think the eGPU is being used, as I’m still getting 30-40 fps, however this can very easily dip and I think the frame-times are also bad as it does not feel consistent.

Here are my logs:
lutris --submit-issue
debug log of battle.net

Thanks,
Brin

I’m not sure if I’m reading this right, but at the bottom it says your OpenGL renderer is the integrated Intel one, not the egpu.

From memory (not home to check) you could select the GPU to use in the Lutris settings for the game (enable advanced settings)

Thanks for the response.

I looked through the settings in Lutris and there is on called “use dedicated GPU” that is turned on but that does not seem to be the cause of the issue.

Is it possible that the bnet app is launching with the eGPU while wow is not?

Do you see any difference when in your WTF config file change gxAPI to GLL or OpenGL?

Hi @Dwuimienny,
I tried changing this settings, however after launching the game I see that it gets reverted back to d3d12 so I am not sure if it helps with anything.

That is working as intended. Do you check FPS after changing gxAPI? BTW try to install gamemode (sudo apt install gamemode) and enable feral gamemode under System options in Lutris for WoW, You could also deactivate option: Prefer systems libraries. Do aforementioned steps and then check performance again.

Hello again,
thanks for the suggestions, however, this is definitely not an issue with system resources. I have tried both GLL & OpenGL alongside with game mode. It seems like the gpu is somehow not as effective? Inside of Windows 10 I can easily get 60FPS on graphics 7/10, in Linux it’s 3/10 to get 40-50 fps. This is a big disparity and I feel like I’m missing some setting or something along those lines. It might also be that the eGPU support on Linux is sadly inferior? I’m not quite sure, but I think it does not have anything to do with the settings for wow.

Bumping this up, still an issue, considering doing an EGPU pass through on a VM as a workaround…

I was having a similar issue. I found that by turning vsync off, the FPS went up to the correct numbers. Hope it helps.