Back to the main site

World of Warcraft & DXVK with AMD


#1

Hi! I’ve tried a couple of configs in order to get WoW working with DXVK, however up to this day I still get the Unsupported 3D acceleration card common error.

My GPU is a R9 280X,. I’m running the raedon driver on ubuntu 18.04lts, I have vulkan installed and I’ve followed the blizzard guide. I am able to use DXVK with Heroes of the Storm, however I can’t make it work in WoW!
I’m running Mesa 18.1.5

Not even the 0.54 dxvk version works for me!
I don’t want to play Battle For Azeroth with the 15-20 fps I get just running it with wine. Can some good horde member give me a hand? (I won’t discriminate Alliance players either).

edit: misstyped mesa version


#2

Have you installed mesa-vulkan-drivers:i386?


#3

Make sure you have all the 32bit libraries installed (vulkan / loaders and so on), WoW needs the 32bit stuff. I’m personally running WoW with latest DXVK and a 290X, and it runs flawlessly :slight_smile:


#4

The step that you’re probably missing is enabling the AMDGPU driver in the kernel. You modify grub to do this.

Check this out : https://askubuntu.com/questions/1041394/vk-error-incompatible-driver-error-with-vulkan-on-ati-sapphire-7870-running-xu

Don’t forget to update-grub then reboot after modifying grub. Then use “vulkan-smoketest” to check if vulkan is working for you now. :wink:


#6

sudo nano /etc/default/grub

add ( radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 modprobe.blacklist=radeon ) after quiet splash to be like this :

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 modprobe.blacklist=radeon"

press ctrl+x to save then press y to accept and enter to confirm

sudo update-grub

then restart your computer


#7

@Ahmed.Elsayed and @BloodyIron you guys were right, i AM missing the AMDGPU driver in the kernel!!

I have a R9 280X (sea island) so I should be able to run vulkan.
I tried your suggestions and edited GRUB, however I can’t move to AMDGPU

eze@pop-os:~$ lspci -k | grep -EA3 'VGA|3D|Display' 
20:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
	Subsystem: XFX Pine Group Inc. Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] (Tahiti XTL [Radeon R9 280X])
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu

I tried blacklisting the radeon driver (tried both using blacklist.conf on modprobe.d and also tried editing the blacklist from grub, as one of the guides say), however I still can’t force AMDGPU to run instead of RADEON.

Any suggestions?
Ty 4 the answers, really it amazes me that there is so much helpful people there is! :smiley:


#8

I would say revisit if you’ve correctly updated your grub config, because that’s what I had to do with an R9 280 to get AMDGPU and Vulkan going. I didn’t need to blacklist radeon.


#9

I edited my previous comment. Please follow it, and update your kernel to the last version.

and install all mesa-vulkan-drivers like this:

sudo apt install mesa-vulkan-drivers

sudo apt install mesa-vulkan-drivers:i386

sudo apt install vulkan-utils


#10

I have a southern Islands card and I’m also having trouble to activate amdgpu. Blacklisting worked with older kernels (I think until 4.12 or 13) but I’m using 4.17.0 (Liquorix backported to stretch) now and those switches don’t work.
Please post if you manage to get it right.


#11

Hi!
I tried those, vulkan drivers seem to be properly installed.

eze@pop-os:~$ lspci -k | grep -EA3 'VGA|3D|Display' 
20:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
	Subsystem: XFX Pine Group Inc. Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] (Tahiti XTL [Radeon R9 280X])
	Kernel driver in use: radeon
	Kernel modules: radeon, amdgpu

I tried quite a bit of things:
-updating mesa drivers (tried padoka (doesn’t work on my system), tried oibaf (currently in use) and the official one (it’s ok, but I like oibaf more).
-updating kernel, tried different versions, currently on:

 eze@pop-os:~$ uname -r
4.18.5-041805-generic

I tried blacklisting the radeon driver so the AMDGPU will just start working by default. I tried several ways to blacklist it, and the moment I was able to blacklist it properly I just got no driver (I mean, it wasn’t radeon and it wasn’t AMDGPU, so the reslution was really low and there was no driver shown on the command, so AMDGPU doesn’t work on my system?)

I edited /etc/default/grub several ways, pretty much all the combinations I could think of, and I updated grub afterwards.

Still I can’t get AMDGPU to work at all.

Isn’t RADV supposed to make Vulkan work on Radeon drivers? How come I don’t have it?
AMDGPU-PRO isn’t supported by my GPU.


#12

Same goes to you, if you find a way to have AMDGPU running, or vulkan running, remember telling me please :slight_smile:


#13

@kaimon

I forgot to mention; I get this:

eze@pop-os:~$ vulkaninfo
===========
VULKAN INFO
===========

Vulkan Instance Version: 1.1.70

ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
/build/vulkan-Kbdbga/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:2700: failed with VK_ERROR_INITIALIZATION_FAILED

#14

AMD doesn’t care about Linux. That is why you will find odd bugs like this one that you need to fix manually. I use Laptop so I can’t change my GPU from AMD to Nvidia, but you can, so consider changing to Nvidia for better support. Don’t get me wrong, It is just a friendly advice.


#15

Actually, AMD is the only one caring about Linux - working together with the Linux developers on free and open drivers instead of just distributing a proprietary one as nvidia does. Just compare the generally good performance of radeon to the shitty performance of nouveau.

That being said, Sea Islands and Southern Islands cards have only experimental support from amdgpu. Since amdgpu worked for me with the older regular liquorix kernels (by blacklisting) I’m suspecting a kernel problem. I’m using the liquorix backport for stretch. Which one do you use ForsakenLive?


#16

AMD stopped making closed drivers for my card since 2015, and the only option is Mesa.

The only reason that AMD support open-source is that they don’t care about Linux enough to give it their full support. On the other hand, Nvidia maintain professional support for for their proprietary drivers, and you can even choose between many versions of Nvidia drivers, while in AMD you have none working proprietary drivers! Which one will win in your opinion?!!

Look at this data-sheet for Steam Play Compatibility (only 28% use Mesa while 67% use Nvidia)

https://docs.google.com/spreadsheets/d/e/2PACX-1vQ3_odz8JzEVK80vkku-b6FsICWb45xGf4VYnzYz5cNSMVQ-5BA2WoHBGAScw96MgLj1ONA7Cx0tyGa/pubhtml#

Mesa did a great job maintaining AMD GPUs, but it is not their job. Besides that you can’t change AMD settings like in AMD closed-drivers, and you have to use DRI_PRIME=1 %command% with every single game to be able to use your AMD card with Mesa, and you can’t force Vsync, and you need to do the workaround that I mentioned before to be able to use your AMD card!


#17

Many Mesa developers are AMD employees.


#18

Why they didn’t make a graphical interface to control AMD settings? And something like Nvidia-prime to switch between Intel and AMD gpu? Is it that hard for them or it is Nvidia exclusive?!


#19

I don’t know why.
You can give feedback through Twitter https://twitter.com/Radeon

You can also try opening a bug on bugs.freedesktop.org