Back to the main site

World of warcraft doesn't start (no error message)


#1

After updating to 0.5 Battle.net doesn’t start anymore. System is debian stable, no vulkan (dxvk disabled).

Also game shortcuts stopped working, they now start the lutris window instead of launching the games directly.

Everything worked perfect before the upgrade. What would be the best way to downgrade? Where can I find a 0.4.x deb? They seem to be gone everywhere.

Edit: I found v. 0.4.23 here: https://sourceforge.net/projects/makulu/files/repository-14/packages/. I really would prefer to have an official download source but it seems that all official 0.4.x packages were wiped. :frowning:

Edit2: Downgrading did not help. There seems to be a problem with Blizzard. Unfortunately the error message is just “unexpected error”.

Edit3: I changed the wine version to 3.21 (default) and battle.net starts again. But WoW doesn’t. Or better said: It starts but I can’t see it.

Edit4: I tried to reinstall WoW - did not work from the website but I could right-click in lutris and chose “install again”. Disabled dxvk. Now everything works again. But I better stick with lutris 0.4.23 for now.


#2

Similar issues here as well. Probably gonna have to wipe the install and try it from scratch.

Edit: No dice with a straight reinstall, best way to get battle.net to run again was to directly launch the battle.net executable.


#3

Yeah, similar problem for me to. Could not start battlenet or wow. I had proton as my wine version but if I changed that to esync-staging-pba-3.16-x86_64 both battle net and wow works again. I also enabled esync in options(not sure what it does,have not read up on that) Anyone knows why proton is not working in 0.5 ?