World of Warcraft doesn't launch from


I have followed the guide, installed WoW but when I press play closes to tray and then either opens up again or says “the games has quit”. I have run this before on Manjaro, I am trying Antergos at the moment, I have everything up-to-date. I have searched for a similar problem but the solution doesn’t work with my case. Is there anything I need to do in order to run it in Antergos?

Thank you.

Run lutris from the command line with verbose flag

lutris -d

and post logs of what happens after you try to launch the game.

Which version of wine you use, and do you use DXVK or not ?

I had to change the game executable from Launcher.exe to under Game Options.

Using esync-staging-pba-3.16-x86_64 with DXVK

That didn’t work for me, thanks anyway.

changed esync-staging-pba-3.16-x86_64 to Wine 3.18 and it works…is that ok or should I use esync?

Esync will perform better. To use it, you have to change some system defaults, see here.
Did you increase the open file limit? What does running ulimit -Hn in a terminal show?

Just a thought-
Have you tried adding WoW to Lutris directly, as opposed to Battle Net?
Game executable = Wow.exe in the WoW installation directory.

Wow.exe will run the game
World of Warcraft Launcher.exe will open the Battle Net app.

Is your graphic card support Vulkan ? If not you should change PBA_ENABLE to 1 and disable DXVK, I recommend increase __PBA_GEO_HEAP too.

Thank you all for your help, it worked the solutions to change Esync defaults, I had 4k something and changed to 100k and it’s all good.

Thank you for your help.