World Of Warcraft BFA / DXVK (AMD)

Been reading around on posts similar to my problem but what to seem to help others doesn’t help me.

I get “Your 3D accelerator card isn’t supported” popup when trying to run the game under VXDK. I followed the instructions and tried 0.61, 0.63, 0.54 and 0.70 version DXVK with same result.
I also tried a different version of wine, staging-3.11, 3.15, pba-firebat-3.11

I tried both with and without PBA_DISABLE=1 and DXVK_FAKE_DX10_SUPPORT=1

But since i’m new on Lutris and how it works i might have done something wrong.

I got latest mesa drivers.
GRAPHICS: XFX AMD Radeon R9 290/390 8192MB
OpenGL: 4.5 Mesa 18.3.0-devel (LLVM 6.0.1)

I also tried adding the graphic card in grub,
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (rev 80)
Subsystem: XFX Pine Group Inc. Hawaii PRO [Radeon R9 290/390]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

I got the game working if I skip using VXDK but have lots of graphics glitches (white squares), the game is playable though. But I rather have it fully working, since you don’t really know if you are standing in something you shouldn’t when everything under you is just a white square.

Please help :slight_smile: