World of Warcraft and a Hardware upgrade

I had just replaced my GT-730 with a GTX-1050 Ti
The bad news is that as soon as I hit play as usual in lutris, the screen goes black and stays that way.

Any ideas?

Make sure you video card works. Perhaps reinstall drivers. Make sure you are running NVidia for OpenGL:

glxinfo | grep OpenGL

well nothing changed. it was just a card swap.
booted in windows and drivers updated and worked great.

just my X goes black in linux.
glxinfo says:
~ # glxinfo |grep -i opengl
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1050 Ti/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 390.48
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.48
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.48
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

and glxgears work.
just when i run or wow-64.exe, darkness descends.

Just like you said: Nothing should have changed. So it should work.

However, it doesn’t. Just for the record: you did you completely uninstall and reinstall Nvidia drivers in Linux? Thats what I had to do when I switched from 670 to 970.

If you already did that you can try to setup a new prefix for WoW, by rightclicking WoW and installing another version. Just add a “2” to the directory it suggests, so you get a fresh prefix there.

For the rest I wouldn’t know what to try.

I did recompile the NVidia driver 390.48
I’ll try a fresh new prefix.

It cannot be anything big, but it is most annoying to have to reboot just to play.

oh well…
fresh prefix does the same.
all runners go black as well…

well, for anyone interested, I recompiled my kernel since the NVidia installer said that it was compiled with GCC-5.3 and I am on GCC-5.5. the Nvidia installer did not complain but she still goes dark on launching the game. ( Slackware64+Alien’s multilib.)
both and Wow-64.exe goes black when launched.
I have awesome performance in Windows, so I know the card works.

I got it working.
I set my display to my samsung monitor with nvidia-settings & wrote it to my xorg.conf

then things worked with;
~$ cd $WoWDIR
~$ WINEPREFIX=~/ ~/.local/share/lutris/runners/wine/pba-3.3-x86_64/bin/wine64 Wow-64.exe

I’ll write a quick and dirty wrapper shell script for it and tinker with Lutris at my leisure.

Well, thats wierd.

Can you try “disable runtime” in Lutris for WoW, then see if you don’t have a black screen? It is based on Ubuntu 16.04, but you are on Slack. I could be that it isn’t working nicely together.

funny enough it went black when i tried that.
i can only break out of that black with a ctrl+alt+backspace

i am just happy that i can play for now… oh and for interest’s sake the same situation ocurred with League of Legends.
utter strangeness…
so far i see no difference yet between -d3d9 and -d3d11 FPS yoyos between 20 and about 80. i get 150 in windows but i still prefer to stay linux.

Make sure you have CSMT enabled for PBA, the Lutris installer sets it for WoW-64.exe. But you created a prefix by hand, so you have to enable it yourself.

thanks for reminding me!
i actually went back to using my original prefix. so most of the essentials should be default.
i am rather pleased with myself for recovering this far… who would have thought that a card upgrade in the same brand and family would misbehave so terribly!

Can you try disabling streaming in Blizzard App, then start the game? (In lutris)

No need, anymore. Thanks!
It is working perfectly now.

Here is what I figure; Things worked great once I did a export LUTRIS_RUNTIME=0 before firing up Lutris. But! WoW minimised and I had to Alt+Tab to get it back and THEN my screen turned into a 640x480 viewport over a 1920x1080 virtual window.

So I opened nvidia-settings as root, and under “X Display Configuration”, I changed my resolution from Auto to 1920x1080 and freq from Auto to 50Hz, hut “Apply” and clicked “Save to X Configuration file” to write it to my xorg.conf.

I rebooted and voila, Lutris is making me happy once more.
I guess it was something to do with that crazy resolution change…

If you play WoW in WIndowed Fullscreen it will probably work better. It won’t affect your desktop either. Fullscreen works differently depending on your DE env.

ahh thanks for that tip.
i use fluxbox so my machine is rather lightweight.

Yeah, I have AwesomeWM myself. If I don’t play Windowed Fullscreen when my mouse goes out of the fullscreen window it minimizes annoyingly.