Back to the main site

World of Warcraft 8.2 isn't run by the battle.net app

Hello, everyone!

The required

  1. lutris --submit-issue: https://paste.ubuntu.com/p/T7kpSJ4B4S/
  2. lutris -d: https://paste.ubuntu.com/p/nMQwMbbgpq/
  3. game log: https ://paste.ubuntu.com/p/kWJFWP6Qr2/ (seems to be included by lutris -d)

It looks like

When I click “Play” in the bnet launcher it glows grey for a while and switches back to blue.
It doesn’t launch the game as it should.

Failed approaches

  1. I started just with a separate wineprefix + corefonts, switched to Lutris https ://lutris.net/games/world-of-warcraft/ , but still have the same result.
  2. For lutris I used the addictivetips guide https ://www.addictivetips.com/ubuntu-linux-tips/play-world-of-warcraft-on-linux/.
  3. The game wiki https ://github.com/lutris/lutris/wiki/Game:-World-of-Warcraft didn’t help.
  4. Battle. net launcher page https ://github.com/lutris/lutris/wiki/Game:-Blizzard-App was useless by itself (I have no problems with this app), however contained useful links.
  5. Wine dependencies https ://github.com/lutris/lutris/wiki/Wine-Dependencies I had already installed.
  6. DXVK page https ://github.com/lutris/lutris/wiki/How-to:-DXVK advanced me through actions, but not to a solution. I updated my nvidia drivers up to 418.56, installed vulkan for both architecrures and installed d9vk, as in the video guide https ://www.youtube.com/watch?v=q2zEQ5Jm28A.
  7. As suggested in common issues with crashes https ://github.com/doitsujin/dxvk/wiki/Common-issues#crashes I tried run with setting WINEDLLOVERRIDES="d3d11,dxgi=b" on the “System options” game tab. Again - no gain.
  8. As a last resort I tried:
    • Setting runner to esync-staging-pba-3.18 https ://www.maketecheasier.com/play-world-of-warcraft-ubuntu/.
    • Disabling lutris runtime.
    • Switching windows from 10 to 7 and back https ://github.com/doitsujin/dxvk/issues/964#issuecomment-499947891.
    • And even unpacked clear cache https ://github.com/Bromeego/WoW-Cache/blob/master/Cache.zip into the client.

Nothing worked. So I’ve got completely lost.

Please help to find out the root problem and possible solutions. Thanks in advance!

1 Like

+1 I have the same issue exactly